summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-12-14 09:42:26 +0100
committerAndreas Kling <kling@serenityos.org>2021-12-16 22:48:16 +0100
commit13680ae0380367217358d94d1fe877b88fd7bea3 (patch)
treeffcd26a9a746107e6f929022961b6c47ad6926e6 /Kernel/CMakeLists.txt
parent39e3c68e947a1ed893e1501cd00fd9f59eb90d9f (diff)
downloadserenity-13680ae0380367217358d94d1fe877b88fd7bea3.zip
Kernel: Build with -O2 by default
We used to build with -Os in order to fit within a certain size, but there isn't really a good reason for that kind of restriction. Switching to -O2 yields a significant improvement in throughput, for example `test-js` is roughly 20% faster on my machine. :^)
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 41655c5cba..00d4c80cfc 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -2,7 +2,7 @@ if (ENABLE_EXTRA_KERNEL_DEBUG_SYMBOLS)
add_compile_options(-Og)
add_compile_options(-ggdb3)
else()
- add_compile_options(-Os)
+ add_compile_options(-O2)
endif()
if ("${SERENITY_ARCH}" STREQUAL "aarch64")