summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorUndefine <undefine@undefine.pl>2022-09-18 18:21:10 +0200
committerAndrew Kaster <andrewdkaster@gmail.com>2022-10-14 18:36:40 -0600
commit135ca3fa1b676c172c1bb2ec0e92487d0af2f4a5 (patch)
tree8da708c264e61dbf70ca717e4e0d057dda16c3c9 /Kernel/CMakeLists.txt
parent9718667bcff664070d2c0bb466124b98c2cceac2 (diff)
downloadserenity-135ca3fa1b676c172c1bb2ec0e92487d0af2f4a5.zip
Kernel: Add support for the FAT32 filesystem
This commit adds read-only support for the FAT32 filesystem. It also includes support for long file names.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 02ed2d5c03..1b575db4a5 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -111,6 +111,7 @@ set(KERNEL_SOURCES
FileSystem/DevPtsFS.cpp
FileSystem/DevTmpFS.cpp
FileSystem/Ext2FileSystem.cpp
+ FileSystem/FATFileSystem.cpp
FileSystem/FIFO.cpp
FileSystem/File.cpp
FileSystem/FileBackedFileSystem.cpp