summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-03-28 21:32:28 +0200
committerAndreas Kling <kling@serenityos.org>2021-03-28 21:32:28 +0200
commitd454926e0fccd71706586cf8d58e83e7cc4f92b5 (patch)
treeee3e4f2921e68a9cbf63413e34610b9779044f34 /CMakeLists.txt
parent9f656b6fa98439132bce394fe46f2691cb9afa90 (diff)
downloadserenity-d454926e0fccd71706586cf8d58e83e7cc4f92b5.zip
cmake: Hotfix the broken build
This regressed in #6000 and started complaining about bad literal suffixes, so here's a quick and dirty partial revert to make things build again.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 985ce1c050..847e26df41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,12 @@ set(CMAKE_CXX_STANDARD 20)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
+if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
+ add_compile_options(-fconcepts -Wno-literal-suffix)
+elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ add_compile_options(-Wno-overloaded-virtual -Wno-user-defined-literals)
+endif()
+
if (ENABLE_ALL_THE_DEBUG_MACROS)
include(${CMAKE_SOURCE_DIR}/Meta/CMake/all_the_debug_macros.cmake)
endif(ENABLE_ALL_THE_DEBUG_MACROS)