summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGunnar Beutner <gbeutner@serenityos.org>2021-05-01 11:38:19 +0200
committerAndreas Kling <kling@serenityos.org>2021-05-01 12:40:12 +0200
commitce77caf479a8f7003d3789737a888cec628efae3 (patch)
tree2af893629c445a738c2583c03fa2a77fe95405fa /CMakeLists.txt
parentf05086a5d2d4e070bfedd431287de335890a9be2 (diff)
downloadserenity-ce77caf479a8f7003d3789737a888cec628efae3.zip
LibC: Move crypt() and crypt_r() to the right header file
According to POSIX.1 these should be in <crypt.h>.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da833bb6d4..3d5809188e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -208,7 +208,9 @@ endif()
add_link_options(--sysroot ${CMAKE_BINARY_DIR}/Root)
include_directories(Userland/Libraries/LibC)
+include_directories(Userland/Libraries/LibCrypt)
include_directories(Userland/Libraries/LibM)
+include_directories(Userland/Libraries/LibPthread)
include_directories(Userland/Libraries/LibSystem)
include_directories(Userland/Services)
include_directories(Userland)