summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-05-17 18:48:37 +0200
committerAndreas Kling <kling@serenityos.org>2021-05-17 19:30:12 +0200
commita15c7b7944a8e6116f30f33c4aeead7a7d5cc0c9 (patch)
tree4a184299c8a149a7de832d3682bc84673283913f /CMakeLists.txt
parenta5603c35dff13715ea094351ccecc08ac1a334c7 (diff)
downloadserenity-a15c7b7944a8e6116f30f33c4aeead7a7d5cc0c9.zip
Build: Stop using precompiled headers (PCH)
This had very bad interactions with ccache, often leading to rebuilds with 100% cache misses, etc. Ali says it wasn't that big of a speedup in the end anyway, so let's not bother with it. We can always bring it back in the future if it seems like a good idea.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae7e29f035..0c591256f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,6 @@ option(ENABLE_ALL_THE_DEBUG_MACROS "Enable all debug macros to validate they sti
option(ENABLE_COMPILETIME_FORMAT_CHECK "Enable compiletime format string checks" ON)
option(ENABLE_PCI_IDS_DOWNLOAD "Enable download of the pci.ids database at build time" ON)
option(BUILD_LAGOM "Build parts of the system targeting the host OS for fuzzing/testing" OFF)
-option(PRECOMPILE_COMMON_HEADERS "Precompile some common headers to speedup compilation" OFF)
option(ENABLE_KERNEL_LTO "Build the kernel with link-time optimization" OFF)
add_custom_target(run