summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Elliott <pelliott@ualberta.ca>2021-04-02 21:53:41 -0600
committerAndreas Kling <kling@serenityos.org>2021-04-12 14:06:24 +0200
commit938924f36de1f335903608c28c4ba5284d5dd883 (patch)
tree9c6fa78bc702ccc2b01b85d87719ead859d7b7d2 /CMakeLists.txt
parent9c3948ef3e496839a7ae5f6bd4cfb93b7eada682 (diff)
downloadserenity-938924f36de1f335903608c28c4ba5284d5dd883.zip
Meta: Add install-ports CMake target
install-ports copys the necessary files from Ports/ to /usr/Ports. Also refactor the compiler and destiation variables from .port_include.sh into .hosted_defs.sh. .hosted_defs.sh does not exists when ports are built in serenity
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 847e26df41..cebc9eb83a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,6 +67,11 @@ add_custom_target(check-style
USES_TERMINAL
)
+add_custom_target(install-ports
+ COMMAND ${CMAKE_COMMAND} -E env "SERENITY_ROOT=${CMAKE_SOURCE_DIR}" "SERENITY_ARCH=${SERENITY_ARCH}" ${CMAKE_SOURCE_DIR}/Meta/install-ports-tree.sh
+ USES_TERMINAL
+)
+
set(CMAKE_CXX_STANDARD 20)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)