summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaster <andrewdkaster@gmail.com>2021-01-17 14:25:12 -0700
committerAndreas Kling <kling@serenityos.org>2021-02-28 18:19:37 +0100
commite787738c24754ce591b4226715fcc2049e37334f (patch)
treed9cdcb4ce712665ff4294bb25c911d0a8ce18222 /CMakeLists.txt
parent860a3bbce342067069d4c7d2e4396a667ff324fe (diff)
downloadserenity-e787738c24754ce591b4226715fcc2049e37334f.zip
Meta: Build AK and LibRegex tests in Lagom and for Serenity
These tests were never built for the serenity target. Move their Lagom build steps to the Lagom CMakeLists.txt, and add serenity build steps for them. Also, fix the build errors when building them with the serenity cross-compiler :^)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d53990a12..d969c02899 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -99,8 +99,6 @@ include_directories(${CMAKE_BINARY_DIR})
add_subdirectory(Meta/Lagom)
add_subdirectory(Userland/DevTools/IPCCompiler)
add_subdirectory(Userland/Libraries/LibWeb/CodeGenerators)
-add_subdirectory(AK/Tests)
-add_subdirectory(Userland/Libraries/LibRegex/Tests)
set(write_if_different ${CMAKE_SOURCE_DIR}/Meta/write-only-on-difference.sh)