summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSahan Fernando <sahan.h.fernando@gmail.com>2020-12-26 18:42:36 +1100
committerAndreas Kling <kling@serenityos.org>2020-12-26 10:05:50 +0100
commite665ad92af3dc2926fdbccec686fbf7a35fb1fe6 (patch)
tree85982714d017a9767912f7df1cea664f118cc7c4 /CMakeLists.txt
parentd780e2265d81cd80dd18f92f5e1ef41e5db6ab36 (diff)
downloadserenity-e665ad92af3dc2926fdbccec686fbf7a35fb1fe6.zip
Everywhere: Add -Wformat=2 to build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 180f1639d3..bd680d8240 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,7 +46,7 @@ set(CMAKE_CXX_STANDARD 20)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
-add_compile_options(-Wno-unknown-warning-option -Wall -Wextra -Werror -Wmissing-declarations -fdiagnostics-color=always -ftls-model=initial-exec)
+add_compile_options(-Wno-unknown-warning-option -Wall -Wextra -Werror -Wmissing-declarations -Wformat=2 -fdiagnostics-color=always -ftls-model=initial-exec)
if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
add_compile_options(-fconcepts)