summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGunnar Beutner <gbeutner@serenityos.org>2021-07-03 00:50:22 +0200
committerAndreas Kling <kling@serenityos.org>2021-07-04 01:07:28 +0200
commite1ff30a3605e9242ee30525b04adb71bcc9162db (patch)
treee1fa668b9d8024d34d7c6f64e58e2fcc0f49c064 /CMakeLists.txt
parent371c852fc01a0019e1e008f145d9b95aef7c9b6d (diff)
downloadserenity-e1ff30a3605e9242ee30525b04adb71bcc9162db.zip
Toolchain+Userland: Enable TLS for x86_64
This is not technically a toolchain change, but it does require rebuilding the toolchain for x86_64 (and just that).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 62fd60c753..992292e470 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,11 +93,6 @@ set(CMAKE_CXX_STANDARD 20)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
-if("${SERENITY_ARCH}" STREQUAL "x86_64")
- # FIXME: Implement TLS support and get rid of this
- add_compile_definitions(NO_TLS X86_64_NO_TLS)
-endif()
-
add_compile_options(-Wno-literal-suffix)
if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
add_compile_options(-fconcepts)