summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Wiederhake <BenWiederhake.GitHub@gmx.de>2020-09-12 00:43:51 +0200
committerAndreas Kling <kling@serenityos.org>2020-09-12 13:46:15 +0200
commitd25860f53c7dd2e53460a5673e71b17ffecefc27 (patch)
tree8d223ec9f79f88f624e57c020e954d4bbd732bb8 /CMakeLists.txt
parent0d79e57c4daec516cef064f4cbbb8a3e17962f9f (diff)
downloadserenity-d25860f53c7dd2e53460a5673e71b17ffecefc27.zip
Meta: Enable gcc warning about struct vs. class
I know, the tags don't actually matter. However, clang warns by default, and instead of disabling the warning for clang I'd rather enable the warning for gcc.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 427457019b..2060b3997d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,7 +42,7 @@ add_custom_target(check-style
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-unknown-warning-option -Wall -Wextra -Werror -Wmissing-declarations -std=c++2a -fdiagnostics-color=always")
if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fconcepts")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fconcepts -Wmismatched-tags")
elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-overloaded-virtual")
endif()