summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGunnar Beutner <gbeutner@serenityos.org>2021-07-29 08:48:47 +0200
committerAndreas Kling <kling@serenityos.org>2021-07-29 10:38:31 +0200
commitb7ca269b4d0142c30b0920402340b3718e226494 (patch)
treedfea265ef414c0859a820ee8ec69d61b160b5221 /CMakeLists.txt
parenta68d912dc02bf82c120872af219b58bbd019f59d (diff)
downloadserenity-b7ca269b4d0142c30b0920402340b3718e226494.zip
Kernel: Use our toolchain's c++filt tool for the kernel map
The host's version of c++filt might not work on some operating systems, e.g. macOS.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef53cc942f..f3192236c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -175,6 +175,7 @@ else()
set(CMAKE_STRIP ${TOOLCHAIN_PREFIX}strip)
set(CMAKE_AR ${TOOLCHAIN_PREFIX}gcc-ar)
set(CMAKE_OBJCOPY ${TOOLCHAIN_PREFIX}objcopy)
+ set(CMAKE_CXXFILT ${TOOLCHAIN_PREFIX}c++filt)
endif()
foreach(lang ASM C CXX OBJC OBJCXX)