summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-12-06 22:57:20 +0100
committerAndrew Kaster <andrewdkaster@gmail.com>2022-12-12 21:34:09 -0700
commit10d40af16743df93de58e4d9fac51139b7e3130d (patch)
tree4f6c6e79612115ee4bd078c075b68c08f5e2d7e9 /CMakeLists.txt
parent0bd9a94bea46bceefbc40b449ea761579a4b37a7 (diff)
downloadserenity-10d40af16743df93de58e4d9fac51139b7e3130d.zip
Meta: Separate ccache setup into its own component
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index caa641ea78..b0a2201a4a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,11 +41,7 @@ if(NOT COMMAND serenity_option)
endif()
include(serenity_options)
-find_program(CCACHE_PROGRAM ccache)
-if(CCACHE_PROGRAM)
- set(CMAKE_C_COMPILER_LAUNCHER "${CCACHE_PROGRAM}" CACHE FILEPATH "Path to a compiler launcher program, e.g. ccache")
- set(CMAKE_CXX_COMPILER_LAUNCHER "${CCACHE_PROGRAM}" CACHE FILEPATH "Path to a compiler launcher program, e.g. ccache")
-endif()
+include(setup_ccache)
if (NOT HACKSTUDIO_BUILD)