summaryrefslogtreecommitdiff
path: root/Applications/Browser/CMakeLists.txt
diff options
context:
space:
mode:
authorFalseHonesty <thefalsehonesty@gmail.com>2020-05-23 12:53:09 -0400
committerAndreas Kling <kling@serenityos.org>2020-05-24 02:20:08 +0200
commit391237a8e1dcd4467702977b51f23adf3a9e640d (patch)
treee6a1d472e66bd6f099aae4f93f6ec7cc71673846 /Applications/Browser/CMakeLists.txt
parent5e45d6844289b772c9538e398eb1b779568e1124 (diff)
downloadserenity-391237a8e1dcd4467702977b51f23adf3a9e640d.zip
Browser: Add JS Console
The JavaScript console can be opened with Control+I, or using the menu option. The console is currently a text box with JS syntax highlighting which will send commands to the document's interpreter. All output is printed to an HTML view in the console. The output is an HtmlView to easily allow complex output, such as expandable views for JS Objects in the long run.
Diffstat (limited to 'Applications/Browser/CMakeLists.txt')
-rw-r--r--Applications/Browser/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Applications/Browser/CMakeLists.txt b/Applications/Browser/CMakeLists.txt
index a75572ccde..d1132f8a6d 100644
--- a/Applications/Browser/CMakeLists.txt
+++ b/Applications/Browser/CMakeLists.txt
@@ -1,5 +1,7 @@
set(SOURCES
BookmarksBarWidget.cpp
+ BrowserConsoleClient.cpp
+ ConsoleWidget.cpp
DownloadWidget.cpp
InspectorWidget.cpp
main.cpp