summaryrefslogtreecommitdiff
path: root/AK/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2023-02-05 12:27:38 +0200
committerLinus Groh <mail@linusgroh.de>2023-02-10 09:14:20 +0000
commitab27fce86f18341d463bc921a2071aefc0071a93 (patch)
tree31e521505d8e1964d4c4f3ef32ccefa10f6e5427 /AK/CMakeLists.txt
parentdf72c9327b1c33e3113c7949ec05b8febecf29c9 (diff)
downloadserenity-ab27fce86f18341d463bc921a2071aefc0071a93.zip
AK: Add a new method to propagate errno while printing errors in Kernel
This new method is meant to be used in both userspace and kernel code. The idea is to allow printing of a verbose message and then returning an errno code which is the proper mechanism for kernel code because we should almost always assume that such error will be propagated back to userspace in some way, so the userspace code could reasonably decode it. For userspace code however, this new method is meant to be a simple wrapper for Error::from_string_view, because for most invocations, it's much more useful to have a verbose & literal error than a errno code, so we simply ignore that errno code completely in such context.
Diffstat (limited to 'AK/CMakeLists.txt')
-rw-r--r--AK/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/AK/CMakeLists.txt b/AK/CMakeLists.txt
index 2988ada7ff..8ce72a78c9 100644
--- a/AK/CMakeLists.txt
+++ b/AK/CMakeLists.txt
@@ -4,6 +4,7 @@ set(AK_SOURCES
CircularBuffer.cpp
DeprecatedFlyString.cpp
DeprecatedString.cpp
+ Error.cpp
FloatingPointStringConversions.cpp
FlyString.cpp
Format.cpp