summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRichard Diamond <wichard@vitalitystudios.com>2014-11-08 23:15:19 -0600
committerRichard Diamond <wichard@vitalitystudios.com>2014-11-08 23:15:19 -0600
commitf32940294d3addf3780e12782135115874bd7649 (patch)
treeeb952b4cc374c4adfb65310042e2185b0ceb53cc /Cargo.toml
parent766ce4b7785c0b038bee95b74564e5b9bf7e9a4b (diff)
downloadrust-openssl-f32940294d3addf3780e12782135115874bd7649.zip
Add overrideable platform ssl.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4c61dd7e..28300444 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,3 +13,24 @@ path = "src/lib.rs"
tlsv1_2 = []
tlsv1_1 = []
sslv2 = []
+
+[target.i686-apple-darwin.dependencies.openssl-sys]
+ git = "https://github.com/alexcrichton/openssl-sys"
+[target.x86_64-apple-darwin.dependencies.openssl-sys]
+ git = "https://github.com/alexcrichton/openssl-sys"
+[target.i686-unknown-linux-gnu.dependencies.openssl-sys]
+ git = "https://github.com/alexcrichton/openssl-sys"
+[target.x86_64-unknown-linux-gnu.dependencies.openssl-sys]
+ git = "https://github.com/alexcrichton/openssl-sys"
+[target.i686-unknown-freebsd.dependencies.openssl-sys]
+ git = "https://github.com/alexcrichton/openssl-sys"
+[target.x86_64-unknown-freebsd.dependencies.openssl-sys]
+ git = "https://github.com/alexcrichton/openssl-sys"
+[target.le32-unknown-nacl.dependencies.openssl-sys]
+ git = "https://github.com/alexcrichton/openssl-sys"
+[target.arm-unknown-nacl.dependencies.openssl-sys]
+ git = "https://github.com/alexcrichton/openssl-sys"
+[target.i686-unknown-nacl.dependencies.openssl-sys]
+ git = "https://github.com/alexcrichton/openssl-sys"
+[target.x86_64-unknown-nacl.dependencies.openssl-sys]
+ git = "https://github.com/alexcrichton/openssl-sys"