summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorStuart Stock <stuart@int08h.com>2018-02-24 22:36:08 -0600
committerStuart Stock <stuart@int08h.com>2018-02-24 22:40:14 -0600
commitca97effa01f977ae775e8f8249421b9fc6d64e72 (patch)
treed315ab8663b4f89feac240fa2ef48917c8aea19f /Cargo.toml
parentae47aa86ed2157325c70a8a9582aecd3857bc15d (diff)
downloadroughenough-ca97effa01f977ae775e8f8249421b9fc6d64e72.zip
Use simple_logger instead of fern
Fern's configurability and features are overkill. As a bonus, compile time and binary size both shrink a bit.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 57bd058..6e7aa34 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,14 +12,15 @@ keywords = ["roughtime", "cryptography", "crypto"]
travis-ci = { repository = "int08h/roughenough", branch = "master" }
[dependencies]
+mio = "0.6"
byteorder = "1"
ring = "0.12"
untrusted = "0.5.1"
time = "0.1"
-log = "0.3"
-fern = "0.4"
+log = "0.4.1"
+simple_logger = "0.5"
yaml-rust = "0.3.5"
-ctrlc = { version = "3.0", features = ["termination"] }
+ctrlc = { version = "3.1", features = ["termination"] }
[dev-dependencies]
criterion = "0.2.0"