summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAaron Hill <aa1ronham@gmail.com>2018-03-01 20:00:05 -0500
committerAaron Hill <aa1ronham@gmail.com>2018-03-11 16:13:47 -0400
commit3471e04b9b28ded3d12ef31a2477a06ec71ae97e (patch)
treea6bd1191e6ee228d89e4e93915d0a1dd1bdd9410 /Cargo.toml
parent8900bc7fab8eeeff2d3801c1bf951c8e57cffa33 (diff)
downloadroughenough-3471e04b9b28ded3d12ef31a2477a06ec71ae97e.zip
Add support for batch-signing requests
As documented in the Roughtime spec, servers can batch together requests, only signing the root of a computed Merkle tree, in order to increase efficiency. Following the example of the reference Roughtime implementation, the default batch size is set to 64. However, this value can be changed in the config. Two pieces of benchmark infrastructure are added - a simple "benchmark mode" on the server, and a "stress test mode" on the client. These features can be used to help pick an optimal batch size for the server. In "benchmark mode", the server does not log any requests. Instead, it prints out the current request processing speed every second. This helps to keep the output manageable when using the client's "stress test" mode. In "stress test mode", the client sends the same message to the server in a loop. To prevent accidental flooding of the users's local network, or a remote server, only loopback addresses are supported in this mode.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e2af555..999efa4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,6 +13,7 @@ travis-ci = { repository = "int08h/roughenough", branch = "master" }
[dependencies]
mio = "0.6"
+mio-extras = "2.0"
byteorder = "1"
ring = "0.12"
untrusted = "0.5"