summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorStuart Stock <stuart@int08h.com>2018-02-17 11:39:08 -0600
committerStuart Stock <stuart@int08h.com>2018-02-17 11:39:46 -0600
commit11808c6356c2a5966ddaeb18341fcdc2290c9179 (patch)
treec801845297f66d102d36c361f6fcd9073026d7c4 /Cargo.toml
parent031de4b338e8a7256b3201913da560c59d427776 (diff)
downloadroughenough-11808c6356c2a5966ddaeb18341fcdc2290c9179.zip
Add benchmarks for message and response creation
As `[bench]` isn't in stable Rust yet, use [Criterion.rs]https://github.com/japaric/criterion.rs) as the benchmarking harness.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c29f852..57bd058 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -21,3 +21,9 @@ fern = "0.4"
yaml-rust = "0.3.5"
ctrlc = { version = "3.0", features = ["termination"] }
+[dev-dependencies]
+criterion = "0.2.0"
+
+[[bench]]
+name = "messages"
+harness = false