summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/README6
-rw-r--r--debian/patches/brl-enlarge.diff74
-rw-r--r--debian/patches/brl-menu.diff51
-rw-r--r--debian/patches/brl-menu.reconf37
-rw-r--r--debian/patches/manpage.diff29
-rw-r--r--debian/patches/series3
6 files changed, 90 insertions, 110 deletions
diff --git a/debian/patches/README b/debian/patches/README
index bc24704..1101a32 100644
--- a/debian/patches/README
+++ b/debian/patches/README
@@ -17,6 +17,6 @@ by the .diff.gz all together.
* If you are preparing a new version
- Start with the clean source from CVS. Choose which of the patches you
- want to apply and apply them. Copy the debian directory (without the
- CVS directories) and build.
+ Start with the clean source from git or the tarball. Choose which of the patches
+ from this directy you want to apply and apply them. Copy the debian directory
+ and build.
diff --git a/debian/patches/brl-enlarge.diff b/debian/patches/brl-enlarge.diff
index 2bcc350..fb06b22 100644
--- a/debian/patches/brl-enlarge.diff
+++ b/debian/patches/brl-enlarge.diff
@@ -1,8 +1,12 @@
-Index: ChangeLog
+This patch adds new removeleft/up/right/down commands to extend the current
+frame in the given direction, removing all frames in the way.
+Default key-bindings are C-t M-arrow-keys.
+
+Index: ratpoison-1.4.4/ChangeLog
===================================================================
---- ChangeLog.orig 2007-04-16 18:33:29.000000000 +0200
-+++ ChangeLog 2007-04-16 18:33:33.000000000 +0200
-@@ -1,1 +1,18 @@
+--- ratpoison-1.4.4.orig/ChangeLog 2009-04-27 04:05:45.000000000 +0200
++++ ratpoison-1.4.4/ChangeLog 2009-04-27 14:43:28.000000000 +0200
+@@ -1,3 +1,20 @@
+2005-06-28 Bernhard R. Link <brlink@debian.org>
+
+ * src/split.c: new functions enlarge_frame_{left,up,right,down}
@@ -20,12 +24,14 @@ Index: ChangeLog
+
+ * doc/ratpoison.1: Document the new commands and keybindings.
+
- 2006-12-19 Shawn Betts <sabetts@shitbender.gagrod>
-Index: doc/ratpoison.1
+ commit 18ee1ed3b3839d44e08e5aefd0e926d29d252654
+ Author: Shawn Betts <sabetts@gmail.com>
+ Date: Fri Apr 24 15:28:27 2009 -0700
+Index: ratpoison-1.4.4/doc/ratpoison.1
===================================================================
---- doc/ratpoison.1.orig 2007-04-16 18:33:29.000000000 +0200
-+++ doc/ratpoison.1 2007-04-16 18:33:33.000000000 +0200
-@@ -499,6 +499,18 @@
+--- ratpoison-1.4.4.orig/doc/ratpoison.1 2009-04-13 14:31:28.000000000 +0200
++++ ratpoison-1.4.4/doc/ratpoison.1 2009-04-27 14:43:28.000000000 +0200
+@@ -511,6 +511,18 @@
.cmd remove ( C\-t R )
Remove the current frame and extend some frames around to fill the remaining
gap.
@@ -44,13 +50,13 @@ Index: doc/ratpoison.1
.cmd resize [ deltax deltay ] ( C\-t r )
If \fIdeltax\fP and \fIdeltay\fP are supplied, resize the current frame
by that (i.e. move the bottom right corner by the given offsets and then
-Index: src/actions.c
+Index: ratpoison-1.4.4/src/actions.c
===================================================================
---- src/actions.c.orig 2007-04-16 18:33:29.000000000 +0200
-+++ src/actions.c 2007-04-16 18:33:33.000000000 +0200
-@@ -283,6 +283,10 @@
+--- ratpoison-1.4.4.orig/src/actions.c 2009-04-13 14:49:08.000000000 +0200
++++ ratpoison-1.4.4/src/actions.c 2009-04-27 14:43:28.000000000 +0200
+@@ -324,6 +324,10 @@
"Hook: ", arg_HOOK,
- "Command: ", arg_REST);
+ "Command: ", arg_COMMAND);
add_command ("remove", cmd_remove, 0, 0, 0);
+ add_command ("removeup", cmd_removeup, 0, 0, 0);
+ add_command ("removedown", cmd_removedown, 0, 0, 0);
@@ -59,7 +65,7 @@ Index: src/actions.c
add_command ("resize", cmd_resize, 2, 0, 2,
"", arg_NUMBER,
"", arg_NUMBER);
-@@ -744,6 +748,10 @@
+@@ -785,6 +789,10 @@
add_keybinding (XK_Down, 0, "focusdown", map);
add_keybinding (XK_Q, 0, "only", map);
add_keybinding (XK_R, 0, "remove", map);
@@ -70,7 +76,7 @@ Index: src/actions.c
add_keybinding (XK_f, 0, "fselect", map);
add_keybinding (XK_f, RP_CONTROL_MASK, "fselect", map);
add_keybinding (XK_F, 0, "curframe", map);
-@@ -2871,6 +2879,38 @@
+@@ -2957,6 +2965,38 @@
}
cmdret *
@@ -109,11 +115,11 @@ Index: src/actions.c
cmd_shrink (int interactive, struct cmdarg **args)
{
push_frame_undo (current_screen()); /* fdump to stack */
-Index: src/actions.h
+Index: ratpoison-1.4.4/src/actions.h
===================================================================
---- src/actions.h.orig 2007-04-16 18:33:29.000000000 +0200
-+++ src/actions.h 2007-04-16 18:33:33.000000000 +0200
-@@ -165,6 +165,10 @@
+--- ratpoison-1.4.4.orig/src/actions.h 2009-04-13 14:02:34.000000000 +0200
++++ ratpoison-1.4.4/src/actions.h 2009-04-27 14:43:28.000000000 +0200
+@@ -168,6 +168,10 @@
RP_CMD (redisplay);
RP_CMD (remhook);
RP_CMD (remove);
@@ -124,11 +130,11 @@ Index: src/actions.h
RP_CMD (rename);
RP_CMD (resize);
RP_CMD (restart);
-Index: src/split.c
+Index: ratpoison-1.4.4/src/split.c
===================================================================
---- src/split.c.orig 2007-04-16 18:33:29.000000000 +0200
-+++ src/split.c 2007-04-16 18:33:33.000000000 +0200
-@@ -703,6 +703,147 @@
+--- ratpoison-1.4.4.orig/src/split.c 2009-04-13 03:52:16.000000000 +0200
++++ ratpoison-1.4.4/src/split.c 2009-04-27 14:47:10.000000000 +0200
+@@ -701,6 +701,147 @@
return 0;
}
@@ -276,7 +282,7 @@ Index: src/split.c
void
remove_frame (rp_frame *frame)
{
-@@ -800,17 +941,7 @@
+@@ -798,17 +939,7 @@
}
if (fits)
@@ -286,16 +292,16 @@ Index: src/split.c
- the new frame size. */
- if (cur->win_number != EMPTY)
- {
-- win = find_window_number (cur->win_number);
+- rp_window *new = find_window_number (cur->win_number);
- maximize_all_windows_in_frame (cur);
-- XRaiseWindow (dpy, win->w);
+- XRaiseWindow (dpy, new->w);
- }
- }
+ maximize_all_in_frame(cur);
else
{
memcpy (cur, &tmp_frame, sizeof (rp_frame));
-@@ -1025,16 +1156,24 @@
+@@ -1030,16 +1161,24 @@
rp_screen *s = frames_screen (frame);
rp_frame *cur;
@@ -321,7 +327,7 @@ Index: src/split.c
}
rp_frame *
-@@ -1043,16 +1182,24 @@
+@@ -1048,16 +1187,24 @@
rp_screen *s = frames_screen (frame);
rp_frame *cur;
@@ -347,7 +353,7 @@ Index: src/split.c
}
rp_frame *
-@@ -1061,16 +1208,24 @@
+@@ -1066,16 +1213,24 @@
rp_screen *s = frames_screen (frame);
rp_frame *cur;
@@ -373,7 +379,7 @@ Index: src/split.c
}
rp_frame *
-@@ -1079,16 +1234,24 @@
+@@ -1084,16 +1239,24 @@
rp_screen *s = frames_screen (frame);
rp_frame *cur;
@@ -399,10 +405,10 @@ Index: src/split.c
}
rp_frame *
-Index: src/split.h
+Index: ratpoison-1.4.4/src/split.h
===================================================================
---- src/split.h.orig 2007-04-16 18:33:29.000000000 +0200
-+++ src/split.h 2007-04-16 18:33:33.000000000 +0200
+--- ratpoison-1.4.4.orig/src/split.h 2009-04-13 03:52:16.000000000 +0200
++++ ratpoison-1.4.4/src/split.h 2009-04-27 14:43:28.000000000 +0200
@@ -33,6 +33,10 @@
void resize_frame_horizontally (rp_frame *frame, int diff);
void resize_frame_vertically (rp_frame *frame, int diff);
diff --git a/debian/patches/brl-menu.diff b/debian/patches/brl-menu.diff
index 8a02db1..8a4b61f 100644
--- a/debian/patches/brl-menu.diff
+++ b/debian/patches/brl-menu.diff
@@ -1,8 +1,11 @@
-Index: ratpoison-1.4.1/ChangeLog
+This patch adds an --with-menu that allows to specify a menu command
+that will be available with :menu and with "C-t ."
+
+Index: ratpoison-1.4.4/ChangeLog
===================================================================
---- ratpoison-1.4.1.orig/ChangeLog 2007-04-16 18:33:33.000000000 +0200
-+++ ratpoison-1.4.1/ChangeLog 2007-04-16 18:34:44.000000000 +0200
-@@ -1,1 +1,7 @@
+--- ratpoison-1.4.4.orig/ChangeLog 2009-04-27 14:43:28.000000000 +0200
++++ ratpoison-1.4.4/ChangeLog 2009-04-27 14:47:28.000000000 +0200
+@@ -1,3 +1,9 @@
+2005-01-15 Bernhard R. Link <brlink@debian.org>
+
+ * configure.in: add --with-menu to specify a menu program
@@ -10,11 +13,13 @@ Index: ratpoison-1.4.1/ChangeLog
+ * src/main.c: tell menu command if menu specified
+
2005-06-28 Bernhard R. Link <brlink@debian.org>
-Index: ratpoison-1.4.1/src/main.c
+
+ * src/split.c: new functions enlarge_frame_{left,up,right,down}
+Index: ratpoison-1.4.4/src/main.c
===================================================================
---- ratpoison-1.4.1.orig/src/main.c 2007-04-16 18:33:29.000000000 +0200
-+++ ratpoison-1.4.1/src/main.c 2007-04-16 18:34:44.000000000 +0200
-@@ -458,7 +458,13 @@
+--- ratpoison-1.4.4.orig/src/main.c 2009-04-13 11:15:46.000000000 +0200
++++ ratpoison-1.4.4/src/main.c 2009-04-27 14:47:28.000000000 +0200
+@@ -467,7 +467,13 @@
{
rp_action *help_action;
char *prefix, *help;
@@ -28,7 +33,7 @@ Index: ratpoison-1.4.1/src/main.c
prefix = keysym_to_string (prefix_key.sym, prefix_key.state);
-@@ -467,27 +473,44 @@
+@@ -476,27 +482,44 @@
/* Find the help key binding. */
help_action = find_keybinding_by_action ("help " ROOT_KEYMAP, map);
if (help_action)
@@ -84,11 +89,11 @@ Index: ratpoison-1.4.1/src/main.c
free (prefix);
}
-Index: ratpoison-1.4.1/src/actions.c
+Index: ratpoison-1.4.4/src/actions.c
===================================================================
---- ratpoison-1.4.1.orig/src/actions.c 2007-04-16 18:33:33.000000000 +0200
-+++ ratpoison-1.4.1/src/actions.c 2007-04-16 18:34:44.000000000 +0200
-@@ -684,6 +684,9 @@
+--- ratpoison-1.4.4.orig/src/actions.c 2009-04-27 14:43:28.000000000 +0200
++++ ratpoison-1.4.4/src/actions.c 2009-04-27 14:47:28.000000000 +0200
+@@ -725,6 +725,9 @@
add_keybinding (prefix_key.sym, prefix_key.state, "other", map);
add_keybinding (prefix_key.sym, 0, "meta", map);
add_keybinding (XK_g, RP_CONTROL_MASK, "abort", map);
@@ -98,7 +103,7 @@ Index: ratpoison-1.4.1/src/actions.c
add_keybinding (XK_0, 0, "select 0", map);
add_keybinding (XK_1, 0, "select 1", map);
add_keybinding (XK_2, 0, "select 2", map);
-@@ -768,6 +771,10 @@
+@@ -811,6 +814,10 @@
add_alias ("unbind", "undefinekey " ROOT_KEYMAP);
add_alias ("bind", "definekey " ROOT_KEYMAP);
add_alias ("split", "vsplit");
@@ -109,13 +114,13 @@ Index: ratpoison-1.4.1/src/actions.c
}
cmdret *
-Index: ratpoison-1.4.1/configure.in
+Index: ratpoison-1.4.4/configure.in
===================================================================
---- ratpoison-1.4.1.orig/configure.in 2007-04-16 18:33:29.000000000 +0200
-+++ ratpoison-1.4.1/configure.in 2007-04-16 18:34:44.000000000 +0200
-@@ -45,6 +45,15 @@
- term_prog=$withval, term_prog="xterm")
- AC_DEFINE_UNQUOTED(TERM_PROG, "$term_prog", X terminal emulator to use)
+--- ratpoison-1.4.4.orig/configure.in 2009-04-27 03:55:10.000000000 +0200
++++ ratpoison-1.4.4/configure.in 2009-04-27 14:47:28.000000000 +0200
+@@ -72,6 +72,15 @@
+ AC_SUBST(XFT_CFLAGS)
+ AC_SUBST(XFT_LIBS)
+AC_ARG_WITH(menu, [ --with-menu=PROG set a external menu program to be advertised ],
+menu_prog="$withval", menu_prog="")
@@ -129,10 +134,10 @@ Index: ratpoison-1.4.1/configure.in
dnl Checks for programs.
AC_CHECK_TOOL(CC, gcc)
AC_PROG_CC
-Index: ratpoison-1.4.1/src/messages.h
+Index: ratpoison-1.4.4/src/messages.h
===================================================================
---- ratpoison-1.4.1.orig/src/messages.h 2007-04-16 18:33:29.000000000 +0200
-+++ ratpoison-1.4.1/src/messages.h 2007-04-16 18:34:44.000000000 +0200
+--- ratpoison-1.4.4.orig/src/messages.h 2009-04-13 03:52:16.000000000 +0200
++++ ratpoison-1.4.4/src/messages.h 2009-04-27 14:47:28.000000000 +0200
@@ -50,6 +50,7 @@
#define MESSAGE_PROMPT_VAR_VALUE "Value: "
diff --git a/debian/patches/brl-menu.reconf b/debian/patches/brl-menu.reconf
index 751dbd3..bc331b3 100644
--- a/debian/patches/brl-menu.reconf
+++ b/debian/patches/brl-menu.reconf
@@ -1,28 +1,28 @@
-Index: ratpoison-1.4.3/configure
+change the autogenerated files the brl-menu.diff would change
+
+Index: ratpoison-1.4.4/configure
===================================================================
---- ratpoison-1.4.3.orig/configure 2008-02-20 18:14:22.000000000 +0100
-+++ ratpoison-1.4.3/configure 2008-02-20 18:24:32.000000000 +0100
-@@ -1312,6 +1312,7 @@
+--- ratpoison-1.4.4.orig/configure 2009-04-27 14:48:49.000000000 +0200
++++ ratpoison-1.4.4/configure 2009-04-27 15:16:28.000000000 +0200
+@@ -1308,6 +1308,7 @@
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
--without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
- --with-xterm=PROG set the x terminal emulator used by ratpoison
-+ --with-menu=PROG set a external menu program to be advertised
+ --with-xterm=PROG set the x terminal emulator used by ratpoison
++ --with-menu=PROG set a external menu program to be advertised
+ --without-xft Don't use the Xft library even if available
--with-x use the X Window System
- Some influential environment variables:
-@@ -2379,6 +2380,27 @@
- _ACEOF
+@@ -2530,7 +2531,24 @@
+ echo "${ECHO_T}no" >&6; }
+ fi
-
-+
+# Check whether --with-menu was given.
+if test "${with_menu+set}" = set; then
+ withval=$with_menu; menu_prog="$withval"
+else
+ menu_prog=""
+fi
-+
-+
+
+if test "$menu_prog" != "no" && ! test -z "$menu_prog" ; then
+
+cat >>confdefs.h <<_ACEOF
@@ -34,15 +34,14 @@ Index: ratpoison-1.4.3/configure
+{ echo "$as_me:$LINENO: result: $menu_prog" >&5
+echo "${ECHO_T}$menu_prog" >&6; }
+fi
-+
+
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args.
- set dummy ${ac_tool_prefix}gcc; ac_word=$2
-Index: ratpoison-1.4.3/src/config.h.in
+Index: ratpoison-1.4.4/src/config.h.in
===================================================================
---- ratpoison-1.4.3.orig/src/config.h.in 2008-02-20 18:14:22.000000000 +0100
-+++ ratpoison-1.4.3/src/config.h.in 2008-02-20 18:24:32.000000000 +0100
-@@ -78,6 +78,9 @@
+--- ratpoison-1.4.4.orig/src/config.h.in 2009-04-27 15:13:46.000000000 +0200
++++ ratpoison-1.4.4/src/config.h.in 2009-04-27 15:14:01.000000000 +0200
+@@ -75,6 +75,9 @@
/* Define to 1 if you have the <X11/extensions/Xinerama.h> header file. */
#undef HAVE_X11_EXTENSIONS_XINERAMA_H
diff --git a/debian/patches/manpage.diff b/debian/patches/manpage.diff
deleted file mode 100644
index d41bf32..0000000
--- a/debian/patches/manpage.diff
+++ /dev/null
@@ -1,29 +0,0 @@
-Index: ratpoison-1.4.3/doc/ratpoison.1
-===================================================================
---- ratpoison-1.4.3.orig/doc/ratpoison.1 2008-02-21 14:34:02.000000000 +0100
-+++ ratpoison-1.4.3/doc/ratpoison.1 2008-02-21 14:58:37.000000000 +0100
-@@ -429,7 +429,6 @@
- .cmd msgwait [ seconds ]
- Set the duration the message window is shown.
- If \fIseconds\fP is zero, wait infinitely.
--.# This will hopefully be changed to set msgwait some day...
- .cmd newkmap keymap
- Generate a new keymap names \fIkeymap\fP. This keymap can
- be used to add new key\-command mapping to it with \fBdefinekey\fP
-@@ -555,7 +554,6 @@
-
- Default is all allowed i.e.\& 15.
-
--.#This will hopefully change to set rudeness and names instead of numbers one day.
- .cmd sdump
- Output the list of all screens.
- The screens are separated by commas. Each screen is shown as 6 values:
-@@ -686,7 +684,7 @@
- .br
- %W by the unit to resize the window horizontally (width_inc)
- .br
--.%x by the xine screen number
-+%x by the xine screen number
- and
- .br
- %% by a single %
diff --git a/debian/patches/series b/debian/patches/series
index f8003c1..13e40f1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,3 @@
-brl-enlarge.diff -p0
+brl-enlarge.diff
brl-menu.diff
brl-menu.reconf
-manpage.diff