summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorsabetts <sabetts>2006-03-15 05:43:38 +0000
committersabetts <sabetts>2006-03-15 05:43:38 +0000
commit9c9e71d4e681112668240c6c0c9715b8f77ed673 (patch)
tree0d818469f129c7f7aecf933c93599f77df00e651 /src/Makefile.am
parent0d47aa583ef5ce0178de264f46fcb028c8592e53 (diff)
downloadratpoison-9c9e71d4e681112668240c6c0c9715b8f77ed673.zip
(init_user_commands): add optional argument to "info"
(cmd_info): handle optional argument * src/format.c: new file * src/format.h: new file * Makefile.am (ratpoison_SOURCES): add format.c and format.h * src/actions.c (set_infofmt): new function (wingravity_to_string): char * instead of static char * because needed in format.c (cmd_info): use format_string * src/actions.h (wingravity_to_string): add prototype * src/data.h (info_fmt): new variable * src/main.c (init_defaults): set a value for defaults.info_fmt * src/ratpoison.h: include format.h * src/windows.c (get_window_list): use format_string (isdigit): remove function as the formatting is now done in format.c (concat_width): likewise (format_window_name): likewise
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 500306f..c9fd5c9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,7 +17,7 @@
## along with this program; if not, write to the Free Software
## Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
##
-## $Id: Makefile.am,v 1.22 2004/12/04 03:33:24 sabetts Exp $
+## $Id: Makefile.am,v 1.23 2006/03/15 05:43:38 sabetts Exp $
bin_PROGRAMS = ratpoison
@@ -35,6 +35,8 @@ ratpoison_SOURCES = actions.c \
editor.h \
events.c \
events.h \
+ format.c \
+ format.h \
frame.c \
frame.h \
getopt.c \