summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBernhard R. Link <brlink@debian.org>2008-05-28 18:59:57 +0200
committerBernhard R. Link <brlink@debian.org>2008-05-28 18:59:57 +0200
commit229ba0708073b0d02ab253290f224a91844f1b17 (patch)
tree405221da55c596e8d663d79543403a9a9a90602c /src/Makefile.am
parentbb3e3db9c29a478939394c612ab93f9d9cdc3bc8 (diff)
downloadratpoison-229ba0708073b0d02ab253290f224a91844f1b17.zip
Only check for xft.pc if xft is not disabled.
If xft is explicitly requested, not finding it causes an error. The CPP and LD flags for the different libraries are put in specific variables and only added in the Makefile.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 64e7163..715c47b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,6 +22,9 @@
bin_PROGRAMS = ratpoison
MAINTAINERCLEANFILES = Makefile.in config.h.in
+AM_LDFLAGS=${X_LDFLAGS} ${X_LIBS} ${X_EXTRA_LIBS} ${XFT_LIBS} ${HISTORY_LIBS}
+AM_CPPFLAGS=${X_CFLAGS} ${XFT_CFLAGS}
+
ratpoison_SOURCES = actions.c \
actions.h \
bar.c \