summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authoralgernon <algernon>2001-04-10 11:54:09 +0000
committeralgernon <algernon>2001-04-10 11:54:09 +0000
commit210c74fd3922224390443fa59bbe61b5fe72d9dd (patch)
tree9dc50ea9cde9bf472904efeb2317637d118b5e49 /debian/rules
parent8a7d48a368ea60c63b69c5659d0acffedaea0011 (diff)
downloadratpoison-210c74fd3922224390443fa59bbe61b5fe72d9dd.zip
sync this one up
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 12 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 13b3f61..20f9631 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,10 @@
#! /usr/bin/make -f
## debian/rules for ratpoison
-## Copyright (C) 2001 Gergely Nagy <8@free.bsd.hu>
+## Copyright (C) 2001 Gergely Nagy <algernon@debian.org>
+##
+## Released under the GNU GPL v2
+##
+## $Id: rules,v 1.6 2001/04/10 11:54:09 algernon Exp $
export DH_COMPAT = 2
DEBHELPER_OPTIONS = -p$@ -Pdebian/$(DEB_HOST_ARCH)/$@
@@ -13,7 +17,10 @@ DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
CFLAGS = -O2
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -g
+ CFLAGS += -g
+ CONFIG_FLAGS += --enable-debug
+else
+ CONFIG_FLAGS += --disable-debug
endif
# bootstrap - for building from CVS snapshots
@@ -33,9 +40,9 @@ build-deb/$(DEB_HOST_ARCH)/config-stamp:
--infodir=/usr/share/info \
--mandir=/usr/share/man \
--with-xterm=x-terminal-emulator \
- --disable-debug \
--build=$(DEB_BUILD_GNU_TYPE) \
- --host=$(DEB_HOST_GNU_TYPE)
+ --host=$(DEB_HOST_GNU_TYPE) \
+ $(CONFIG_FLAGS)
touch $@
# build - build the package
@@ -86,7 +93,7 @@ ratpoison: install
dh_installmanpages $(DEBHELPER_OPTIONS)
dh_installinfo $(DEBHELPER_OPTIONS)
# dh_undocumented $(DEBHELPER_OPTIONS)
- dh_installchangelogs src/ChangeLog $(DEBHELPER_OPTIONS)
+ dh_installchangelogs ChangeLog $(DEBHELPER_OPTIONS)
dh_installwm $(DEBHELPER_OPTIONS)
dh_link $(DEBHELPER_OPTIONS)
dh_strip $(DEBHELPER_OPTIONS)