summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorbrl <brl>2007-05-06 16:07:00 +0000
committerbrl <brl>2007-05-06 16:07:00 +0000
commitbee55fb437fb4be1ba9505f7a49bd75578f5afa3 (patch)
tree212f721ec88b015583384ff1250fe3b2a8243b6d /debian/patches
parentfd9c683b25edd3a56eaaed005fe51545bbb93217 (diff)
downloadratpoison-bee55fb437fb4be1ba9505f7a49bd75578f5afa3.zip
update debian/ subdirectory to 1.4.1-3
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/README2
-rw-r--r--debian/patches/brl-enlarge.diff40
-rw-r--r--debian/patches/brl-menu.diff57
-rw-r--r--debian/patches/brl-menu.reconf16
-rw-r--r--debian/patches/restorededication.patch13
-rw-r--r--debian/patches/series1
6 files changed, 71 insertions, 58 deletions
diff --git a/debian/patches/README b/debian/patches/README
index 544c90c..bc24704 100644
--- a/debian/patches/README
+++ b/debian/patches/README
@@ -5,7 +5,7 @@ by the .diff.gz all together.
* If you are NMUing the Debian package:
Just ignore this directory (unless it helps you to understand what I did).
- Everything applicaple to you .orig.tar.gz should already be in the
+ Everything applicaple to your .orig.tar.gz should already be in the
.diff.gz you have. Just modify the actual code, submit a patch with what
you did to the BTS and let me sort it out and include the patch in this
directory.
diff --git a/debian/patches/brl-enlarge.diff b/debian/patches/brl-enlarge.diff
index 6d62032..2bcc350 100644
--- a/debian/patches/brl-enlarge.diff
+++ b/debian/patches/brl-enlarge.diff
@@ -1,7 +1,7 @@
Index: ChangeLog
===================================================================
---- ChangeLog.orig 2006-10-28 19:56:37.000000000 +0200
-+++ ChangeLog 2006-10-28 19:56:41.000000000 +0200
+--- ChangeLog.orig 2007-04-16 18:33:29.000000000 +0200
++++ ChangeLog 2007-04-16 18:33:33.000000000 +0200
@@ -1,1 +1,18 @@
+2005-06-28 Bernhard R. Link <brlink@debian.org>
+
@@ -20,11 +20,11 @@ Index: ChangeLog
+
+ * doc/ratpoison.1: Document the new commands and keybindings.
+
- 2006-10-03 Shawn Betts <sabetts@vcn.bc.ca>
+ 2006-12-19 Shawn Betts <sabetts@shitbender.gagrod>
Index: doc/ratpoison.1
===================================================================
---- doc/ratpoison.1.orig 2006-10-28 19:56:37.000000000 +0200
-+++ doc/ratpoison.1 2006-10-28 19:56:41.000000000 +0200
+--- doc/ratpoison.1.orig 2007-04-16 18:33:29.000000000 +0200
++++ doc/ratpoison.1 2007-04-16 18:33:33.000000000 +0200
@@ -499,6 +499,18 @@
.cmd remove ( C\-t R )
Remove the current frame and extend some frames around to fill the remaining
@@ -46,9 +46,9 @@ Index: doc/ratpoison.1
by that (i.e. move the bottom right corner by the given offsets and then
Index: src/actions.c
===================================================================
---- src/actions.c.orig 2006-10-28 19:56:37.000000000 +0200
-+++ src/actions.c 2006-10-28 19:56:41.000000000 +0200
-@@ -281,6 +281,10 @@
+--- src/actions.c.orig 2007-04-16 18:33:29.000000000 +0200
++++ src/actions.c 2007-04-16 18:33:33.000000000 +0200
+@@ -283,6 +283,10 @@
"Hook: ", arg_HOOK,
"Command: ", arg_REST);
add_command ("remove", cmd_remove, 0, 0, 0);
@@ -59,7 +59,7 @@ Index: src/actions.c
add_command ("resize", cmd_resize, 2, 0, 2,
"", arg_NUMBER,
"", arg_NUMBER);
-@@ -742,6 +746,10 @@
+@@ -744,6 +748,10 @@
add_keybinding (XK_Down, 0, "focusdown", map);
add_keybinding (XK_Q, 0, "only", map);
add_keybinding (XK_R, 0, "remove", map);
@@ -70,7 +70,7 @@ Index: src/actions.c
add_keybinding (XK_f, 0, "fselect", map);
add_keybinding (XK_f, RP_CONTROL_MASK, "fselect", map);
add_keybinding (XK_F, 0, "curframe", map);
-@@ -2869,6 +2877,38 @@
+@@ -2871,6 +2879,38 @@
}
cmdret *
@@ -111,8 +111,8 @@ Index: src/actions.c
push_frame_undo (current_screen()); /* fdump to stack */
Index: src/actions.h
===================================================================
---- src/actions.h.orig 2006-10-28 19:56:37.000000000 +0200
-+++ src/actions.h 2006-10-28 19:56:41.000000000 +0200
+--- src/actions.h.orig 2007-04-16 18:33:29.000000000 +0200
++++ src/actions.h 2007-04-16 18:33:33.000000000 +0200
@@ -165,6 +165,10 @@
RP_CMD (redisplay);
RP_CMD (remhook);
@@ -126,8 +126,8 @@ Index: src/actions.h
RP_CMD (restart);
Index: src/split.c
===================================================================
---- src/split.c.orig 2006-10-28 19:56:37.000000000 +0200
-+++ src/split.c 2006-10-28 19:56:41.000000000 +0200
+--- src/split.c.orig 2007-04-16 18:33:29.000000000 +0200
++++ src/split.c 2007-04-16 18:33:33.000000000 +0200
@@ -703,6 +703,147 @@
return 0;
}
@@ -295,7 +295,7 @@ Index: src/split.c
else
{
memcpy (cur, &tmp_frame, sizeof (rp_frame));
-@@ -1002,16 +1133,24 @@
+@@ -1025,16 +1156,24 @@
rp_screen *s = frames_screen (frame);
rp_frame *cur;
@@ -321,7 +321,7 @@ Index: src/split.c
}
rp_frame *
-@@ -1020,16 +1159,24 @@
+@@ -1043,16 +1182,24 @@
rp_screen *s = frames_screen (frame);
rp_frame *cur;
@@ -347,7 +347,7 @@ Index: src/split.c
}
rp_frame *
-@@ -1038,16 +1185,24 @@
+@@ -1061,16 +1208,24 @@
rp_screen *s = frames_screen (frame);
rp_frame *cur;
@@ -373,7 +373,7 @@ Index: src/split.c
}
rp_frame *
-@@ -1056,16 +1211,24 @@
+@@ -1079,16 +1234,24 @@
rp_screen *s = frames_screen (frame);
rp_frame *cur;
@@ -401,8 +401,8 @@ Index: src/split.c
rp_frame *
Index: src/split.h
===================================================================
---- src/split.h.orig 2006-10-28 19:56:37.000000000 +0200
-+++ src/split.h 2006-10-28 19:56:41.000000000 +0200
+--- src/split.h.orig 2007-04-16 18:33:29.000000000 +0200
++++ src/split.h 2007-04-16 18:33:33.000000000 +0200
@@ -33,6 +33,10 @@
void resize_frame_horizontally (rp_frame *frame, int diff);
void resize_frame_vertically (rp_frame *frame, int diff);
diff --git a/debian/patches/brl-menu.diff b/debian/patches/brl-menu.diff
index e4b8e47..8a02db1 100644
--- a/debian/patches/brl-menu.diff
+++ b/debian/patches/brl-menu.diff
@@ -1,7 +1,19 @@
-Index: ratpoison/src/main.c
+Index: ratpoison-1.4.1/ChangeLog
===================================================================
---- ratpoison.orig/src/main.c 2006-10-28 19:56:35.000000000 +0200
-+++ ratpoison/src/main.c 2006-10-28 19:56:48.000000000 +0200
+--- ratpoison-1.4.1.orig/ChangeLog 2007-04-16 18:33:33.000000000 +0200
++++ ratpoison-1.4.1/ChangeLog 2007-04-16 18:34:44.000000000 +0200
+@@ -1,1 +1,7 @@
++2005-01-15 Bernhard R. Link <brlink@debian.org>
++
++ * configure.in: add --with-menu to specify a menu program
++ * src/action.c: add menu alias and binding if menu specified
++ * src/main.c: tell menu command if menu specified
++
+ 2005-06-28 Bernhard R. Link <brlink@debian.org>
+Index: ratpoison-1.4.1/src/main.c
+===================================================================
+--- ratpoison-1.4.1.orig/src/main.c 2007-04-16 18:33:29.000000000 +0200
++++ ratpoison-1.4.1/src/main.c 2007-04-16 18:34:44.000000000 +0200
@@ -458,7 +458,13 @@
{
rp_action *help_action;
@@ -72,11 +84,11 @@ Index: ratpoison/src/main.c
free (prefix);
}
-Index: ratpoison/src/actions.c
+Index: ratpoison-1.4.1/src/actions.c
===================================================================
---- ratpoison.orig/src/actions.c 2006-10-28 19:56:41.000000000 +0200
-+++ ratpoison/src/actions.c 2006-10-28 19:56:48.000000000 +0200
-@@ -682,6 +682,9 @@
+--- ratpoison-1.4.1.orig/src/actions.c 2007-04-16 18:33:33.000000000 +0200
++++ ratpoison-1.4.1/src/actions.c 2007-04-16 18:34:44.000000000 +0200
+@@ -684,6 +684,9 @@
add_keybinding (prefix_key.sym, prefix_key.state, "other", map);
add_keybinding (prefix_key.sym, 0, "meta", map);
add_keybinding (XK_g, RP_CONTROL_MASK, "abort", map);
@@ -86,7 +98,7 @@ Index: ratpoison/src/actions.c
add_keybinding (XK_0, 0, "select 0", map);
add_keybinding (XK_1, 0, "select 1", map);
add_keybinding (XK_2, 0, "select 2", map);
-@@ -766,6 +769,10 @@
+@@ -768,6 +771,10 @@
add_alias ("unbind", "undefinekey " ROOT_KEYMAP);
add_alias ("bind", "definekey " ROOT_KEYMAP);
add_alias ("split", "vsplit");
@@ -96,23 +108,11 @@ Index: ratpoison/src/actions.c
+#endif
}
- static cmdret *
-Index: ratpoison/ChangeLog
-===================================================================
---- ratpoison.orig/ChangeLog 2006-10-28 19:56:41.000000000 +0200
-+++ ratpoison/ChangeLog 2006-10-28 19:56:48.000000000 +0200
-@@ -1,1 +1,7 @@
-+2005-01-15 Bernhard R. Link <brlink@debian.org>
-+
-+ * configure.in: add --with-menu to specify a menu program
-+ * src/action.c: add menu alias and binding if menu specified
-+ * src/main.c: tell menu command if menu specified
-+
- 2005-06-28 Bernhard R. Link <brlink@debian.org>
-Index: ratpoison/configure.in
+ cmdret *
+Index: ratpoison-1.4.1/configure.in
===================================================================
---- ratpoison.orig/configure.in 2006-10-28 19:56:36.000000000 +0200
-+++ ratpoison/configure.in 2006-10-28 19:56:48.000000000 +0200
+--- ratpoison-1.4.1.orig/configure.in 2007-04-16 18:33:29.000000000 +0200
++++ ratpoison-1.4.1/configure.in 2007-04-16 18:34:44.000000000 +0200
@@ -45,6 +45,15 @@
term_prog=$withval, term_prog="xterm")
AC_DEFINE_UNQUOTED(TERM_PROG, "$term_prog", X terminal emulator to use)
@@ -129,11 +129,11 @@ Index: ratpoison/configure.in
dnl Checks for programs.
AC_CHECK_TOOL(CC, gcc)
AC_PROG_CC
-Index: ratpoison/src/messages.h
+Index: ratpoison-1.4.1/src/messages.h
===================================================================
---- ratpoison.orig/src/messages.h 2006-10-28 19:56:35.000000000 +0200
-+++ ratpoison/src/messages.h 2006-10-28 19:56:48.000000000 +0200
-@@ -50,7 +50,8 @@
+--- ratpoison-1.4.1.orig/src/messages.h 2007-04-16 18:33:29.000000000 +0200
++++ ratpoison-1.4.1/src/messages.h 2007-04-16 18:34:44.000000000 +0200
+@@ -50,6 +50,7 @@
#define MESSAGE_PROMPT_VAR_VALUE "Value: "
#define MESSAGE_WELCOME "Welcome to ratpoison! Hit `%s %s' for help."
@@ -141,4 +141,3 @@ Index: ratpoison/src/messages.h
#define EMPTY_FRAME_MESSAGE "Current Frame"
- #endif /* ! _RATPOISON_MESSAGES_H */
diff --git a/debian/patches/brl-menu.reconf b/debian/patches/brl-menu.reconf
index db2e287..ad24132 100644
--- a/debian/patches/brl-menu.reconf
+++ b/debian/patches/brl-menu.reconf
@@ -1,8 +1,8 @@
-Index: ratpoison/configure
+Index: ratpoison-1.4.1/configure
===================================================================
---- ratpoison.orig/configure 2006-10-30 17:37:33.000000000 +0100
-+++ ratpoison/configure 2006-10-30 17:38:43.000000000 +0100
-@@ -1295,6 +1295,7 @@
+--- ratpoison-1.4.1.orig/configure 2007-04-16 18:45:18.000000000 +0200
++++ ratpoison-1.4.1/configure 2007-04-16 18:47:11.000000000 +0200
+@@ -864,6 +864,7 @@
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
--without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
--with-xterm=PROG set the x terminal emulator used by ratpoison
@@ -10,7 +10,7 @@ Index: ratpoison/configure
--with-x use the X Window System
Some influential environment variables:
-@@ -2343,6 +2344,27 @@
+@@ -1872,6 +1873,27 @@
_ACEOF
@@ -38,10 +38,10 @@ Index: ratpoison/configure
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args.
set dummy ${ac_tool_prefix}gcc; ac_word=$2
-Index: ratpoison/src/config.h.in
+Index: ratpoison-1.4.1/src/config.h.in
===================================================================
---- ratpoison.orig/src/config.h.in 2006-10-30 17:38:06.000000000 +0100
-+++ ratpoison/src/config.h.in 2006-10-30 17:38:31.000000000 +0100
+--- ratpoison-1.4.1.orig/src/config.h.in 2007-04-16 18:45:18.000000000 +0200
++++ ratpoison-1.4.1/src/config.h.in 2007-04-16 18:47:11.000000000 +0200
@@ -72,6 +72,9 @@
/* Define to 1 if you have the <X11/extensions/Xinerama.h> header file. */
#undef HAVE_X11_EXTENSIONS_XINERAMA_H
diff --git a/debian/patches/restorededication.patch b/debian/patches/restorededication.patch
new file mode 100644
index 0000000..991dfac
--- /dev/null
+++ b/debian/patches/restorededication.patch
@@ -0,0 +1,13 @@
+Index: ratpoison-1.4.1/src/frame.c
+===================================================================
+--- ratpoison-1.4.1.orig/src/frame.c 2007-04-16 18:39:47.000000000 +0200
++++ ratpoison-1.4.1/src/frame.c 2007-04-16 18:49:17.000000000 +0200
+@@ -248,7 +248,7 @@
+ read_slot(dedicated);
+ if (dedicated <= 0)
+ f->dedicated = 0;
+- else if (f->dedicated >= 1)
++ else
+ f->dedicated = 1;
+ }
+ else if (!strcmp(tmp, ")"))
diff --git a/debian/patches/series b/debian/patches/series
index ebfdaf9..a670386 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
brl-enlarge.diff -p0
brl-menu.diff
brl-menu.reconf
+restorededication.patch