summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorBernhard R. Link <brlink@debian.org>2009-10-30 19:05:19 +0100
committerBernhard R. Link <brlink@debian.org>2009-10-30 19:36:11 +0100
commit66f1644c881d8388015016d082e6c8643959fb8c (patch)
tree1c9ba86e0e7057ee78e19d87b5469e3b37ad74cf /debian/patches
parenta9578d667935a6206622e01707cb3cd14d1b112b (diff)
downloadratpoison-66f1644c881d8388015016d082e6c8643959fb8c.zip
update debian/
- to include changes for 1.4.5-2 - to update patches to apply to current git - list explicit commands in debian/README.source how to build from git
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/530176.diff4
-rw-r--r--debian/patches/brl-enlarge.diff13
-rw-r--r--debian/patches/brl-menu.diff3
-rw-r--r--debian/patches/brl-menu.reconf3
-rw-r--r--debian/patches/proper-install-info.diff26
-rw-r--r--debian/patches/series (renamed from debian/patches/_series)0
6 files changed, 17 insertions, 32 deletions
diff --git a/debian/patches/530176.diff b/debian/patches/530176.diff
index a386ab9..3b1779e 100644
--- a/debian/patches/530176.diff
+++ b/debian/patches/530176.diff
@@ -1,3 +1,7 @@
+Author: Bernhard R. Link <brlink@debian.org>
+Description: rpshowall.sh needs bash, so use #!/bin/bash
+Bug: 530176
+
Index: ratpoison-1.4.5/contrib/rpshowall.sh
===================================================================
--- ratpoison-1.4.5.orig/contrib/rpshowall.sh 2009-07-14 15:10:18.000000000 +0200
diff --git a/debian/patches/brl-enlarge.diff b/debian/patches/brl-enlarge.diff
index fb06b22..513faee 100644
--- a/debian/patches/brl-enlarge.diff
+++ b/debian/patches/brl-enlarge.diff
@@ -1,3 +1,6 @@
+Author: Bernhard R. Link <brlink@debian.org>
+Subject: add removeleft/up/right/down commands
+
This patch adds new removeleft/up/right/down commands to extend the current
frame in the given direction, removing all frames in the way.
Default key-bindings are C-t M-arrow-keys.
@@ -80,7 +83,7 @@ Index: ratpoison-1.4.4/src/actions.c
}
cmdret *
-+cmd_removeup (int interactive, struct cmdarg **args)
++cmd_removeup (int interactive UNUSED, struct cmdarg **args UNUSED)
+{
+ push_frame_undo (current_screen()); /* fdump to stack */
+ enlarge_frame_up (current_frame(), 1);
@@ -88,7 +91,7 @@ Index: ratpoison-1.4.4/src/actions.c
+}
+
+cmdret *
-+cmd_removedown (int interactive, struct cmdarg **args)
++cmd_removedown (int interactive UNUSED, struct cmdarg **args UNUSED)
+{
+ push_frame_undo (current_screen()); /* fdump to stack */
+ enlarge_frame_down (current_frame(), 1);
@@ -96,7 +99,7 @@ Index: ratpoison-1.4.4/src/actions.c
+}
+
+cmdret *
-+cmd_removeleft (int interactive, struct cmdarg **args)
++cmd_removeleft (int interactive UNUSED, struct cmdarg **args UNUSED)
+{
+ push_frame_undo (current_screen()); /* fdump to stack */
+ enlarge_frame_left (current_frame(), 1);
@@ -104,7 +107,7 @@ Index: ratpoison-1.4.4/src/actions.c
+}
+
+cmdret *
-+cmd_removeright (int interactive, struct cmdarg **args)
++cmd_removeright (int interactive UNUSED, struct cmdarg **args UNUSED)
+{
+ push_frame_undo (current_screen()); /* fdump to stack */
+ enlarge_frame_right (current_frame(), 1);
@@ -112,7 +115,7 @@ Index: ratpoison-1.4.4/src/actions.c
+}
+
+cmdret *
- cmd_shrink (int interactive, struct cmdarg **args)
+ cmd_shrink (int interactive UNUSED, struct cmdarg **args UNUSED)
{
push_frame_undo (current_screen()); /* fdump to stack */
Index: ratpoison-1.4.4/src/actions.h
diff --git a/debian/patches/brl-menu.diff b/debian/patches/brl-menu.diff
index 8a4b61f..61998da 100644
--- a/debian/patches/brl-menu.diff
+++ b/debian/patches/brl-menu.diff
@@ -1,3 +1,6 @@
+Author: Bernhard R. Link <brlink@debian.org>
+Subject: add --with-menu
+
This patch adds an --with-menu that allows to specify a menu command
that will be available with :menu and with "C-t ."
diff --git a/debian/patches/brl-menu.reconf b/debian/patches/brl-menu.reconf
index bc331b3..a929add 100644
--- a/debian/patches/brl-menu.reconf
+++ b/debian/patches/brl-menu.reconf
@@ -1,4 +1,5 @@
-change the autogenerated files the brl-menu.diff would change
+Author: Bernhard R. Link <brlink@debian.org>
+Subject: change the autogenerated files the brl-menu.diff would change
Index: ratpoison-1.4.4/configure
===================================================================
diff --git a/debian/patches/proper-install-info.diff b/debian/patches/proper-install-info.diff
deleted file mode 100644
index 7ecf8e4..0000000
--- a/debian/patches/proper-install-info.diff
+++ /dev/null
@@ -1,26 +0,0 @@
-This patch is needed when the .orig.tar.gz you are building for is
-generated by a automake version having problems with Debian's
-install-info command.
-
-Index: ratpoison-1.4.0.dfsg/doc/Makefile.in
-===================================================================
---- ratpoison-1.4.0.dfsg.orig/doc/Makefile.in 2006-06-26 11:10:08.000000000 +0200
-+++ ratpoison-1.4.0.dfsg/doc/Makefile.in 2006-06-26 11:11:08.000000000 +0200
-@@ -151,7 +151,7 @@
- uninstall-info-am:
- $(PRE_UNINSTALL)
- @if (install-info --version && \
-- install-info --version | fgrep -i -v debian) >/dev/null 2>&1; then \
-+ install-info --version 2>&1 | sed 1q | fgrep -i -v debian) >/dev/null 2>&1; then \
- list='$(INFO_DEPS)'; \
- for file in $$list; do \
- echo " install-info --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file"; \
-@@ -324,7 +324,7 @@
- done
- @$(POST_INSTALL)
- @if (install-info --version && \
-- install-info --version | fgrep -i -v debian) >/dev/null 2>&1; then \
-+ install-info --version 2>&1 | sed 1q | fgrep -i -v debian) >/dev/null 2>&1; then \
- list='$(INFO_DEPS)'; \
- for file in $$list; do \
- echo " install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file";\
diff --git a/debian/patches/_series b/debian/patches/series
index 964105e..964105e 100644
--- a/debian/patches/_series
+++ b/debian/patches/series