summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsabetts <sabetts>2002-11-20 09:29:37 +0000
committersabetts <sabetts>2002-11-20 09:29:37 +0000
commitd8b1104be304c1c67db4f16389696ea82a3e6699 (patch)
tree09e160a1339b2cccc700884419265234f2155f4b /configure.in
parent34703b2c03d6f5eb15b9357d9ba6fc707944aa98 (diff)
downloadratpoison-d8b1104be304c1c67db4f16389696ea82a3e6699.zip
* src/ratpoison.h[!HAVE_VARARG_MACROS]: PRINT_ERROR and
PRINT_DEBUG are defined as void macros. * src/events.c (client_msg): Add semicolon to the end of a PRINT_DEBUG line. * src/actions.c (cmd_bind): typecast data as a (char *) before using it in (char *) pointer arithmetic. * configure.in: Add check to see if the preprocessor has variable argument macro capabilities.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a98eeb5..97f9d94 100644
--- a/configure.in
+++ b/configure.in
@@ -17,7 +17,7 @@ dnl You should have received a copy of the GNU General Public License
dnl along with this program; if not, write to the Free Software
dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
dnl
-dnl $Id: configure.in,v 1.30 2002/03/10 20:42:55 sabetts Exp $
+dnl $Id: configure.in,v 1.31 2002/11/20 09:29:37 sabetts Exp $
AC_INIT(src/main.c)
AM_INIT_AUTOMAKE(ratpoison, 1.2.0-cvs)
@@ -44,10 +44,25 @@ term_prog=$withval, term_prog="xterm")
AC_DEFINE_UNQUOTED(TERM_PROG,"$term_prog")
dnl Checks for programs.
-CFLAGS="$CFLAGS -Wall -O2"
AC_CHECK_TOOL(CC, gcc)
AC_PROG_CC
+if test "x$CC" = "xgcc"; then
+ CFLAGS="$CFLAGS -Wall -O2"
+fi
+
+dnl Check for vararg macros (some preprocessors don't have variable argument macros)
+AC_PROG_CPP
+AC_MSG_CHECKING(for vararg macros)
+AC_TRY_CPP([
+#define VARARGS(first, more...) foo(first, ## more)
+VARARGS(bar, gazonk)
+VARARGS(bar, gazonk, blahonga)
+], AC_DEFINE_UNQUOTED(HAVE_VARARG_MACROS, "1", The c preprocessor has support for vararg macros) AC_MSG_RESULT(yes),
+AC_MSG_RESULT(no))
+
+
+
dnl check for an x terminal emulator
AC_MSG_CHECKING(terminal emulator)
AC_MSG_RESULT($term_prog)