summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMidare Kiyura <puce@gmx.com>2008-05-24 16:04:33 -0500
committerShawn <sabetts@juicebox.(none)>2008-05-24 23:41:09 -0700
commitd37c7484ab881b0283fd4573235b24fe7d1e7af9 (patch)
tree981341de090bb7834ab4617aed763218d9c7e8f5 /configure.in
parentc7ec59674cfe315f2a0ea54fc7444b4a6a6a8a67 (diff)
downloadratpoison-d37c7484ab881b0283fd4573235b24fe7d1e7af9.zip
Add xft support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0af99b7..c850575 100644
--- a/configure.in
+++ b/configure.in
@@ -42,6 +42,20 @@ AC_ARG_WITH(xterm, [ --with-xterm=PROG set the x terminal emulator used b
term_prog=$withval, term_prog="xterm")
AC_DEFINE_UNQUOTED(TERM_PROG, "$term_prog", X terminal emulator to use)
+dnl Use the Xft library if desired.
+AC_MSG_CHECKING(whether to use Xft)
+AC_ARG_WITH(xft,
+ AC_HELP_STRING([--with-xft], [use the Xft library for fonts]),
+ [if test "x$withval" != "xno"; then
+ AC_DEFINE_UNQUOTED(USE_XFT_FONT, 1, [Define this to use Xft])
+ CFLAGS="$CFLAGS `pkg-config --cflags xft`"
+ LDFLAGS="$LDFLAGS `pkg-config --libs xft`"
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi],
+ [AC_MSG_RESULT(no)])
+
dnl Checks for programs.
AC_CHECK_TOOL(CC, gcc)
AC_PROG_CC