summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsabetts <sabetts>2000-09-07 16:49:23 +0000
committersabetts <sabetts>2000-09-07 16:49:23 +0000
commit60767d1215233461273d4d16df8ff52cf15b4010 (patch)
treed62f90a2f202366b829f274fc21458ab70df6730 /configure.in
parent33fb61429337fc71292628e9dac1ddf599938304 (diff)
downloadratpoison-60767d1215233461273d4d16df8ff52cf15b4010.zip
restructured tree, added automake and autoconf to the build process.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..1e08bbe
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,35 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(src/main.c)
+AM_INIT_AUTOMAKE(ratpoison, 0.0.3)
+
+AM_CONFIG_HEADER(src/config.h)
+
+dnl Checks for programs.
+CFLAGS="$CFLAGS -Wall"
+AC_PROG_CC
+
+dnl Check for the X libs
+AC_PATH_X
+AC_PATH_XTRA
+
+if test "x$no_x" = "xyes"; then
+ AC_MSG_ERROR([*** Can't find X11 headers and libs])
+fi
+
+LDFLAGS="$LDFLAGS $X_LDFLAGS $X_LIBS $X_EXTRA_LIBS"
+CFLAGS="$CFLAGS $X_CFLAGS"
+
+AC_CHECK_LIB(X11, XOpenDisplay,,
+ AC_MSG_ERROR([*** Can't find libX11]))
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS(unistd.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+
+dnl Checks for library functions.
+AC_TYPE_SIGNAL
+
+AC_OUTPUT(Makefile doc/Makefile src/Makefile)