summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsabetts <sabetts>2004-03-02 03:56:35 +0000
committersabetts <sabetts>2004-03-02 03:56:35 +0000
commit54df55b2f7822f9e79d131fe158e43e286b720ec (patch)
treef5626856518aee7ea7d32df206c06af620c79e51 /configure.in
parent1993ca87b91845172cade32b77423c925aa150f1 (diff)
downloadratpoison-54df55b2f7822f9e79d131fe158e43e286b720ec.zip
fix check for Xinerama.h
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2ec5025..b1427e0 100644
--- a/configure.in
+++ b/configure.in
@@ -17,7 +17,7 @@ dnl You should have received a copy of the GNU General Public License
dnl along with this program; if not, write to the Free Software
dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
dnl
-dnl $Id: configure.in,v 1.40 2004/02/27 08:28:16 sabetts Exp $
+dnl $Id: configure.in,v 1.41 2004/03/02 03:56:35 sabetts Exp $
AC_INIT(src/main.c)
AM_INIT_AUTOMAKE(ratpoison, 1.3.0-cvs)
@@ -87,7 +87,9 @@ CFLAGS="$CFLAGS $X_CFLAGS"
AC_CHECK_LIB(X11, XOpenDisplay,,
AC_MSG_ERROR([*** Can't find libX11]))
-AC_CHECK_HEADERS([X11/extensions/Xinerama.h])
+AC_CHECK_HEADERS([X11/extensions/Xinerama.h], [], [], [
+#include <X11/Xlib.h>
+])
AC_CHECK_LIB(Xext, XMissingExtension, [LIBS="-lXext $LIBS"],, $CFLAGS $LDFLAGS)
AC_CHECK_LIB(Xinerama, XineramaQueryScreens, [LIBS="-lXinerama $LIBS"],, $CFLAGS $LDFLAGS)