summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsabetts <sabetts>2002-01-27 00:57:19 +0000
committersabetts <sabetts>2002-01-27 00:57:19 +0000
commit4c4d1845ab1425b9a92ebc86288106a8610d2f69 (patch)
tree894a85497e4a953c82d060b2d8c10c3c897f22ed /configure.in
parent0a53640a044b85a537d49d9ae71a1c69ad08940b (diff)
downloadratpoison-4c4d1845ab1425b9a92ebc86288106a8610d2f69.zip
* configure.in: check for the vsnprintf function and stdarg.h
header. * src/main.c (xvsprintf): Cleaned up to call vsnprintf only in one place. wrap the vsnprintf call with va_copy (or __va_copy) and va_end.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 6e3d8f6..c2f9629 100644
--- a/configure.in
+++ b/configure.in
@@ -17,7 +17,7 @@ dnl You should have received a copy of the GNU General Public License
dnl along with this program; if not, write to the Free Software
dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
dnl
-dnl $Id: configure.in,v 1.24 2002/01/08 19:13:06 algernon Exp $
+dnl $Id: configure.in,v 1.25 2002/01/27 00:57:19 sabetts Exp $
AC_INIT(src/main.c)
AM_INIT_AUTOMAKE(ratpoison, 1.0.1-cvs)
@@ -69,12 +69,13 @@ AC_CHECK_LIB(X11, XOpenDisplay,,
dnl Checks for header files.
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(unistd.h)
+AC_CHECK_HEADERS(unistd.h stdarg.h)
dnl Checks for typedefs, structures, and compiler characteristics.
dnl Checks for library functions.
-AC_CHECK_FUNCS(getopt getopt_long setsid setpgid setpgrp setenv unsetenv)
+AC_CHECK_FUNCS(getopt getopt_long setsid setpgid setpgrp setenv unsetenv vsnprintf )
+
AC_TYPE_SIGNAL
AC_OUTPUT(Makefile doc/Makefile src/Makefile contrib/Makefile)