summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsabetts <sabetts>2003-02-23 01:40:42 +0000
committersabetts <sabetts>2003-02-23 01:40:42 +0000
commit49ca20c9fc7807d612ef9925c110e8da6c3c1a8f (patch)
treef532251c2f3835e9ecd81f46e17900e95603be52 /configure.in
parent5e4c6e4a9729e1ec546535cfc6ee264768c6b987 (diff)
downloadratpoison-49ca20c9fc7807d612ef9925c110e8da6c3c1a8f.zip
* configure.in: don't check for variable argument support in
preprocessor. * src/ratpoison.h (PRINT_LINE): new macro. (PRE_PRINT_LOCATION): remove macro (PRINT_ERROR): takes one argument which is the argument list ,parens and all, to be passed to printf. Callers updated. * src/actions.c (cmd_number): use list delete entry macro (cmd_number): likewise (cmd_escape): use list looping macro (cmd_escape): likewise (cmd_defpadding): likewise (cmd_defborder): likewise * src/events.c (mapping_notify): use list looping macro (mapping_notify): likewise * src/list.c: rename rp_unmapped_window_sentinel to rp_unmapped_window and rp_mapped_window_sentinel to rp_mapped_window. Use LIST_HEAD to create them. externs updated. (add_to_window_list): use list add entry macro. (find_window_in_list): list head is of type list_head. Prototype and callers updated. (find_window_in_list): use list looping macro (init_window_list): remove function (find_window_number): use list looping macro (find_window_name): likewise (find_window_prev): use list previous entry macro (find_window_next): use list next entry macro (find_window_other): use list looping macro (append_to_list): remove function (insert_into_list): use list looping macro (insert_into_list): use list add entry macro (remove_from_list): remove function (get_window_list): use list looping macro * src/main.c (main): do not call init_window_list() * src/manage.c (unmanage): use list delete macro (map_window): likewise (withdraw_window): use list moving macro to move entry to another list. (hide_others): use list looping macro * src/split.c (num_frames): use list looping macro (frames_screen): likewise (maximize_all_windows_in_frame): likewise (delete_frame_from_list): remove function (create_initial_frame): remove list init code. Add current frame to screen's frame list. (init_frame_list): use list init macro (find_last_frame): use list looping macro (find_windows_frame): likewise (find_frame_next): use list next entry macro (find_frame_prev): use list previous entry macro (find_window_for_frame): use list looping macro (split_frame): use list add entry macro (remove_all_splits): use list looping macro (resize_frame_vertically): likewise (resize_frame_horizontally): likewise (total_frame_area): likewise (frame_overlaps): likewise (remove_frame): likewise (find_frame_up): likewise (find_frame_down): likewise (find_frame_left): likewise (find_frame_right): likewise
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 1e0c528..7c60e43 100644
--- a/configure.in
+++ b/configure.in
@@ -17,7 +17,7 @@ dnl You should have received a copy of the GNU General Public License
dnl along with this program; if not, write to the Free Software
dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
dnl
-dnl $Id: configure.in,v 1.32 2002/12/11 20:35:17 sabetts Exp $
+dnl $Id: configure.in,v 1.33 2003/02/23 01:40:42 sabetts Exp $
AC_INIT(src/main.c)
AM_INIT_AUTOMAKE(ratpoison, 1.2.0-cvs)
@@ -51,18 +51,6 @@ if test "x$CC" = "xgcc"; then
CFLAGS="$CFLAGS -Wall -O2"
fi
-dnl Check for vararg macros (some preprocessors don't have variable argument macros)
-AC_PROG_CPP
-AC_MSG_CHECKING(for vararg macros)
-AC_TRY_CPP([
-#define VARARGS(first, more...) foo(first, ## more)
-VARARGS(bar, gazonk)
-VARARGS(bar, gazonk, blahonga)
-], AC_DEFINE_UNQUOTED(HAVE_VARARG_MACROS, "1", The c preprocessor has support for vararg macros) AC_MSG_RESULT(yes),
-AC_MSG_RESULT(no))
-
-
-
dnl check for an x terminal emulator
AC_MSG_CHECKING(terminal emulator)
AC_MSG_RESULT($term_prog)