summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsabetts <sabetts>2004-09-29 15:33:13 +0000
committersabetts <sabetts>2004-09-29 15:33:13 +0000
commit442b8d1ae2f4419ca2e2e4d76ad06ae38d18d1c7 (patch)
tree0f8560315ca338841e8d70fbcff55ad995dbbe61 /configure.in
parent6206d6ac617f244700cebb319fd9e53636cfbd83 (diff)
downloadratpoison-442b8d1ae2f4419ca2e2e4d76ad06ae38d18d1c7.zip
* configure.in: Warn when the history header or library is not
found and compile without history support. * src/ratpoison.h: change ifdef to check for HAVE_HISTORY. * src/manage.c (get_state): change data to an unsigned char and cast data to a long* when it's used. * src/main.c (main): change ifdef to check for HAVE_HISTORY. (clean_up): likewise * src/history.c: change ifdef to check for HAVE_HISTORY. * src/events.c (receive_command): make prop_return an unsigned char. * src/editor.c (editor_history_previous): change ifdef to check for HAVE_HISTORY. (editor_history_next): likewise (editor_enter): likewise
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 95c71e1..ecee316 100644
--- a/configure.in
+++ b/configure.in
@@ -17,7 +17,7 @@ dnl You should have received a copy of the GNU General Public License
dnl along with this program; if not, write to the Free Software
dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
dnl
-dnl $Id: configure.in,v 1.43 2004/06/14 05:25:50 sabetts Exp $
+dnl $Id: configure.in,v 1.44 2004/09/29 15:33:14 sabetts Exp $
AC_INIT(src/main.c)
AM_INIT_AUTOMAKE(ratpoison, 1.3.1-cvs)
@@ -75,10 +75,12 @@ AC_ARG_ENABLE(history,
fi],[check_for_libhistory=yes])
if test x$check_for_libhistory = xyes ; then
- AC_CHECK_HEADERS([readline/history.h])
- AC_CHECK_LIB(history, add_history,
- LIBS="$LIBS -lhistory",
- AC_MSG_ERROR([*** Can't find History headers and libs]))
+ AC_CHECK_HEADERS([readline/history.h],
+ AC_CHECK_LIB(history, add_history,
+ [LIBS="$LIBS -lhistory"
+ AC_DEFINE_UNQUOTED(HAVE_HISTORY, 1, Define this to enable history)],
+ AC_MSG_WARN([*** Can't find History lib. Install readline dev libs for history.])),
+ AC_MSG_WARN([*** Can't find History header. Install readline dev libs for history.]))
fi
LDFLAGS="$LDFLAGS $X_LDFLAGS $X_LIBS $X_EXTRA_LIBS"