summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBernhard R. Link <brlink@debian.org>2008-06-15 15:40:37 +0200
committerShawn <sabetts@juicebox.(none)>2008-10-22 14:24:45 -0700
commit086cf745280ff944a479508f806fa118839e166f (patch)
tree64012b7060ae974e568bd6e2e2793b9586657ed4 /configure.in
parent1e4c576b14025d4e16e09110c31b1dec5dac85b9 (diff)
downloadratpoison-086cf745280ff944a479508f806fa118839e166f.zip
ignore non-existing libhistory unless --enable-history
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index df323ca..dc45b15 100644
--- a/configure.in
+++ b/configure.in
@@ -95,21 +95,25 @@ fi
dnl Those who do not learn the lessons of history
dnl are doomed to delete it... yuk yuk. --ttn
-AC_ARG_ENABLE(history,AC_HELP_STRING([--disable-history],[ignore libhistory (default: use it)]),
+AC_ARG_ENABLE(history,AC_HELP_STRING([--disable-history],[ignore libhistory (default: use it if available, only used for ! expansion)]),
[ if test x${enableval} = xyes ; then
check_for_libhistory=yes
else
check_for_libhistory=no
- fi],[check_for_libhistory=yes])
+ fi],[check_for_libhistory=default])
HISTORY_LIBS=""
-if test x$check_for_libhistory = xyes ; then
+if test x$check_for_libhistory != xno ; then
AC_CHECK_HEADERS([readline/history.h],
AC_CHECK_LIB(history, add_history,
[HISTORY_LIBS="-lhistory"
AC_DEFINE_UNQUOTED(HAVE_HISTORY, 1, Define this to enable history)],
- AC_MSG_WARN([*** Can't find History lib. Install readline dev libs for history.])),
- AC_MSG_WARN([*** Can't find History header. Install readline dev libs for history.]))
+ if test x$check_for_libhistory = xyes ; then
+ AC_MSG_ERROR([*** Can't find History lib. Install readline dev libs for history expansion.])
+ fi),
+ if test x$check_for_libhistory = xyes ; then
+ AC_MSG_ERROR([*** Can't find History header. Install readline dev libs for history expansion.])
+ fi)
fi
AC_SUBST(HISTORY_LIBS)