summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsabetts <sabetts>2000-12-04 07:04:25 +0000
committersabetts <sabetts>2000-12-04 07:04:25 +0000
commit7ee9190d0849e8df707611b63b42e976bbd8d827 (patch)
treeef1728c08039ab2f7b5897810a42f350a436730a /configure.in
parent3b8d3d379b2778cfdbc2c1e1c6c448303311e20f (diff)
downloadratpoison-7ee9190d0849e8df707611b63b42e976bbd8d827.zip
debugging is now on by default
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8a06578..134fbfc 100644
--- a/configure.in
+++ b/configure.in
@@ -5,7 +5,11 @@ AM_INIT_AUTOMAKE(ratpoison, 0.0.6)
AM_CONFIG_HEADER(src/config.h)
-AC_ARG_ENABLE(debug, [Turn on debugging information], AC_DEFINE(DEBUG))
+dnl by default turn on debugging
+AC_ARG_ENABLE(debug, [ --disable-debug Turn off debugging information], enable_debugging=no, enable_debugging=yes)
+if test "$enable_debugging" = yes; then
+ AC_DEFINE(DEBUG)
+fi
dnl Checks for programs.
CFLAGS="$CFLAGS -Wall"