summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsabetts <sabetts>2001-01-02 15:30:08 +0000
committersabetts <sabetts>2001-01-02 15:30:08 +0000
commit3f6a681c54a8984c84959d4eaf5e222467bd3d00 (patch)
tree1d79374e732738f9e7afe7f8a3198f362cfff3bd /configure.in
parentd5051508bc32eb35a429bf602bfdf7513a5679e1 (diff)
downloadratpoison-3f6a681c54a8984c84959d4eaf5e222467bd3d00.zip
added --with-xterm=PROG option
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 134fbfc..892cd20 100644
--- a/configure.in
+++ b/configure.in
@@ -11,10 +11,21 @@ if test "$enable_debugging" = yes; then
AC_DEFINE(DEBUG)
fi
+AC_ARG_WITH(xterm, [ --with-xterm=PROG set the x terminal emulator used by ratpoison ],
+term_prog=$withval, term_prog="xterm")
+
+AC_DEFINE_UNQUOTED(TERM_PROG,"$term_prog")
+
dnl Checks for programs.
CFLAGS="$CFLAGS -Wall"
AC_PROG_CC
+dnl check for an x terminal emulator
+AC_CHECK_PROG(result,$term_prog,yes,no)
+if test $result = no; then
+ AC_MSG_ERROR([*** Can't find x terminal emulator \`$term_prog'])
+fi
+
dnl Check for the X libs
AC_PATH_X
AC_PATH_XTRA