summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJérémie Courrèges-Anglas <jca@wxcvbn.org>2013-01-21 02:08:18 +0100
committerJérémie Courrèges-Anglas <jca@wxcvbn.org>2013-01-21 03:23:05 +0100
commitc3aa7c8bba7794d8856156ac3c361e952847648d (patch)
tree96e398774d23b4206b3897b4559f9e84bec3c534 /configure.in
parent09a464eb213212ac6538bc4bba9d2e391562b100 (diff)
downloadratpoison-c3aa7c8bba7794d8856156ac3c361e952847648d.zip
more up-to-date autotools practices
* use proper AC_INIT / AM_INIT_AUTOMAKE arguments * install macros in m4/ * install junk build files in build-aux/ * replace hand-rolled autogen.sh by autoreconf -i * sync .gitignore
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index b60e103..e73304b 100644
--- a/configure.in
+++ b/configure.in
@@ -19,8 +19,12 @@ dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
dnl
dnl $Id: configure.in,v 1.54 2006/12/19 22:13:07 sabetts Exp $
-AC_INIT(src/main.c)
-AM_INIT_AUTOMAKE(ratpoison, 1.4.6-GIT)
+
+AC_INIT([ratpoison], [1.4.6-GIT], [ratpoison-devel@nongnu.org])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([src/main.c])
+AM_INIT_AUTOMAKE([-Wall -Werror gnu])
AM_MAINTAINER_MODE
@@ -151,4 +155,5 @@ AC_CHECK_FUNCS(unsetenv usleep vsnprintf)
AC_TYPE_SIGNAL
-AC_OUTPUT(Makefile doc/Makefile src/Makefile contrib/Makefile)
+AC_CONFIG_FILES([Makefile doc/Makefile src/Makefile contrib/Makefile])
+AC_OUTPUT