summaryrefslogtreecommitdiff
path: root/target/mips/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/mips/meson.build')
-rw-r--r--target/mips/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/mips/meson.build b/target/mips/meson.build
index 9741545440..75c1652460 100644
--- a/target/mips/meson.build
+++ b/target/mips/meson.build
@@ -6,12 +6,13 @@ gen = [
]
mips_ss = ss.source_set()
-mips_ss.add(gen)
mips_ss.add(files(
'cpu.c',
'gdbstub.c',
))
-mips_ss.add(when: 'CONFIG_TCG', if_true: files(
+mips_tcg_ss = ss.source_set()
+mips_tcg_ss.add(gen)
+mips_tcg_ss.add(files(
'dsp_helper.c',
'fpu_helper.c',
'lmmi_helper.c',
@@ -36,5 +37,7 @@ mips_softmmu_ss.add(when: 'CONFIG_TCG', if_true: files(
'cp0_helper.c',
))
+mips_ss.add_all(when: 'CONFIG_TCG', if_true: [mips_tcg_ss])
+
target_arch += {'mips': mips_ss}
target_softmmu_arch += {'mips': mips_softmmu_ss}