summaryrefslogtreecommitdiff
path: root/tests/qtest/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2021-01-07 15:57:18 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2021-01-12 12:38:03 +0100
commit2c9dce0196883d76e8bcb7142b26ab7587ff3006 (patch)
treeb1afeaa0973fafc49d4be850fc5ed7430bb26e6d /tests/qtest/meson.build
parentb3f846c59d8405bb87c551187721fc92ff2f1b92 (diff)
downloadqemu-2c9dce0196883d76e8bcb7142b26ab7587ff3006.zip
meson: do not use CONFIG_VIRTFS
CONFIG_VIRTFS is not anymore part of the config_host dictionary. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'tests/qtest/meson.build')
-rw-r--r--tests/qtest/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/qtest/meson.build b/tests/qtest/meson.build
index 6a67c538be..6ec09821d7 100644
--- a/tests/qtest/meson.build
+++ b/tests/qtest/meson.build
@@ -199,7 +199,9 @@ qos_test_ss.add(
'virtio-serial-test.c',
'vmxnet3-test.c',
)
-qos_test_ss.add(when: 'CONFIG_VIRTFS', if_true: files('virtio-9p-test.c'))
+if have_virtfs
+ qos_test_ss.add(files('virtio-9p-test.c'))
+endif
qos_test_ss.add(when: 'CONFIG_VHOST_USER', if_true: files('vhost-user-test.c'))
tpmemu_files = ['tpm-emu.c', 'tpm-util.c', 'tpm-tests.c']