summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2020-09-11 13:12:11 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2020-09-30 19:09:19 +0200
commit27d551c00d5458d1deda33508dab7453959ca2c6 (patch)
tree303df74b795d66e37e49ab876ea09079a721a47e /tests/meson.build
parent8a5701e54a1f6a355072751e40c0ef440a4402b3 (diff)
downloadqemu-27d551c00d5458d1deda33508dab7453959ca2c6.zip
meson: clean up build_by_default
Build all executables by default except for the known-broken ones. This also allows running qemu-iotests without manually building socket_scm_helper. Reported-by: Max Reitz <mreitz@redhat.com> Tested-by: Max Reitz <mreitz@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 8b99e23545..3c2969092d 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -251,12 +251,11 @@ foreach bench_name, deps: benchs
suite: ['speed'])
endforeach
-if have_tools and 'CONFIG_VHOST_USER' in config_host
+if have_tools and 'CONFIG_VHOST_USER' in config_host and 'CONFIG_LINUX' in config_host
executable('vhost-user-bridge',
sources: files('vhost-user-bridge.c'),
link_with: [libvhost_user],
- dependencies: [qemuutil],
- build_by_default: false)
+ dependencies: [qemuutil])
endif
if have_system and 'CONFIG_POSIX' in config_host