summaryrefslogtreecommitdiff
path: root/hw/virtio/meson.build
diff options
context:
space:
mode:
authorViresh Kumar <viresh.kumar@linaro.org>2021-07-09 10:30:17 +0530
committerMichael S. Tsirkin <mst@redhat.com>2021-07-16 11:10:45 -0400
commit538bb6f1219c1711538d73143f005e62c3d20f7b (patch)
treeecc3a6e1f4bec186881e43b7211f0b102f346b4b /hw/virtio/meson.build
parent7221d3b634d1995a63a91de9b5035abf643c7ebc (diff)
downloadqemu-538bb6f1219c1711538d73143f005e62c3d20f7b.zip
hw/virtio: add vhost-user-i2c-pci boilerplate
This allows is to instantiate a vhost-user-i2c device as part of a PCI bus. It is mostly boilerplate which looks pretty similar to the vhost-user-fs-pci device. Reviewed-by: Alex Bennée <alex.bennee@linaro.org> Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org> Message-Id: <8a083eaa57d93feaab12acd1f94b225879212f20.1625806763.git.viresh.kumar@linaro.org> Reviewed-by: Michael S. Tsirkin <mst@redhat.com> Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
Diffstat (limited to 'hw/virtio/meson.build')
-rw-r--r--hw/virtio/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/virtio/meson.build b/hw/virtio/meson.build
index 1a0d736a0d..bc352a6009 100644
--- a/hw/virtio/meson.build
+++ b/hw/virtio/meson.build
@@ -26,6 +26,7 @@ virtio_ss.add(when: 'CONFIG_VIRTIO_RNG', if_true: files('virtio-rng.c'))
virtio_ss.add(when: 'CONFIG_VIRTIO_IOMMU', if_true: files('virtio-iommu.c'))
virtio_ss.add(when: 'CONFIG_VIRTIO_MEM', if_true: files('virtio-mem.c'))
virtio_ss.add(when: 'CONFIG_VHOST_USER_I2C', if_true: files('vhost-user-i2c.c'))
+virtio_ss.add(when: ['CONFIG_VIRTIO_PCI', 'CONFIG_VHOST_USER_I2C'], if_true: files('vhost-user-i2c-pci.c'))
virtio_pci_ss = ss.source_set()
virtio_pci_ss.add(when: 'CONFIG_VHOST_VSOCK', if_true: files('vhost-vsock-pci.c'))