summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index d16e46c..7e0d385 100755
--- a/setup.py
+++ b/setup.py
@@ -5,15 +5,17 @@ import sys
## ATTENTION! when doing releases, the default debugmode in lib/error.py should be set to PRODUCTION.
## (TODO: any nicer ways than doing this manually? Make a "releases" branch, maybe?)
-version = '0.8.1'
+version = '0.9.0dev'
if __name__ == '__main__':
- ## For python 2.7 and 3.5 we depend on pytz and tzlocal. For 3.6 and up, batteries are included. Same with mock.
+ ## For python 2.7 and 3.5 we depend on pytz and tzlocal. For 3.6 and up, batteries are included. Same with mock. (But unfortunately the icalendar library only support pytz timezones, so we'll keep pytz around for a bit longer).
try:
import datetime
from datetime import timezone
- datetime.datetime.now().astimezone()
+ datetime.datetime.now().astimezone(timezone.utc)
extra_packages = []
+ ## line below can be removed when https://github.com/collective/icalendar/issues/333 is fixed
+ extra_packages = ['pytz', 'tzlocal']
except:
extra_packages = ['pytz', 'tzlocal']
try: