summaryrefslogtreecommitdiff
path: root/examples/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Cargo.toml')
-rw-r--r--examples/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/examples/Cargo.toml b/examples/Cargo.toml
index 49c5316..f0caee0 100644
--- a/examples/Cargo.toml
+++ b/examples/Cargo.toml
@@ -13,6 +13,9 @@ defmt-info = []
defmt-warn = []
defmt-error = []
+ble-gatt-server = ["nrf-softdevice/ble-gatt-server"]
+ble-gatt-client = ["nrf-softdevice/ble-gatt-client"]
+
[dependencies]
async-flash = { version = "0.1.0", path = "../async-flash" }
cortex-m = { version = "0.6.3" }
@@ -32,3 +35,15 @@ futures = { version = "0.3.5", default-features = false }
name = "rtic"
required-features = ["cortex-m-rtic"]
+[[bin]]
+name = "ble_bas_peripheral"
+required-features = ["ble-gatt-server"]
+
+[[bin]]
+name = "ble_bas_central"
+required-features = ["ble-gatt-client"]
+
+[[bin]]
+name = "ble_peripheral_gattspam"
+required-features = ["ble-gatt-client"]
+