summaryrefslogtreecommitdiff
path: root/example-rtic/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'example-rtic/Cargo.toml')
-rw-r--r--example-rtic/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/example-rtic/Cargo.toml b/example-rtic/Cargo.toml
new file mode 100644
index 0000000..31ffd5b
--- /dev/null
+++ b/example-rtic/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+authors = ["Dario Nieuwenhuis <dirbaio@dirbaio.net>"]
+edition = "2018"
+name = "nrf-softdevice-example-rtic"
+version = "0.1.0"
+
+[features]
+default = [ "defmt-default" ]
+defmt-default = []
+defmt-trace = []
+defmt-debug = []
+defmt-info = []
+defmt-warn = []
+defmt-error = []
+
+[dependencies]
+cortex-m = { version = "0.6.3" }
+cortex-m-rtic = "0.5.5"
+defmt = "0.1.0"
+defmt-rtt = "0.1.0"
+panic-probe = "0.1.0"
+nrf52840-hal = { version = "0.11.0" }
+nrf-softdevice = { version = "0.1.0", path = "../nrf-softdevice", features = ["defmt-trace", "nrf52840", "s140", "ble-peripheral", "ble-central"] }
+nrf-softdevice-s140 = { version = "0.1.1", path = "../nrf-softdevice-s140" }
+static-executor = { version = "0.1.0", features=["defmt"]}
+static-executor-cortex-m = { version = "0.1.0" }
+futures = { version = "0.3.5", default-features = false }