summaryrefslogtreecommitdiff
path: root/examples/Cargo.toml
diff options
context:
space:
mode:
authorJacob Rosenthal <jacobrosenthal@gmail.com>2020-09-14 18:24:13 -0700
committerJacob Rosenthal <jacobrosenthal@gmail.com>2020-09-14 18:24:13 -0700
commit2f18009dd00e7b3e58815be4dc5d94a7c5d8c964 (patch)
tree9b0c017f770b52388b730a119689732c8338e178 /examples/Cargo.toml
parentd5e3235632e5d233ac38dfb7ee9c61b5277f7029 (diff)
downloadnrf-softdevice-2f18009dd00e7b3e58815be4dc5d94a7c5d8c964.zip
feature gate gatt_client and gatt_server
Diffstat (limited to 'examples/Cargo.toml')
-rw-r--r--examples/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/examples/Cargo.toml b/examples/Cargo.toml
index 49c5316..f0caee0 100644
--- a/examples/Cargo.toml
+++ b/examples/Cargo.toml
@@ -13,6 +13,9 @@ defmt-info = []
defmt-warn = []
defmt-error = []
+ble-gatt-server = ["nrf-softdevice/ble-gatt-server"]
+ble-gatt-client = ["nrf-softdevice/ble-gatt-client"]
+
[dependencies]
async-flash = { version = "0.1.0", path = "../async-flash" }
cortex-m = { version = "0.6.3" }
@@ -32,3 +35,15 @@ futures = { version = "0.3.5", default-features = false }
name = "rtic"
required-features = ["cortex-m-rtic"]
+[[bin]]
+name = "ble_bas_peripheral"
+required-features = ["ble-gatt-server"]
+
+[[bin]]
+name = "ble_bas_central"
+required-features = ["ble-gatt-client"]
+
+[[bin]]
+name = "ble_peripheral_gattspam"
+required-features = ["ble-gatt-client"]
+