summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlan Somers <asomers@gmail.com>2020-05-31 15:35:30 -0600
committerAlan Somers <asomers@gmail.com>2020-05-31 19:07:15 -0600
commitfb76c213edcb0ef8a403ddc03d27d6975afe1a10 (patch)
treeb92cd991da344f348561fc5b21518ae2ceef4abd /Cargo.toml
parent1ae5dd8b16aed61958fd3ce488ed7fd459743652 (diff)
downloadnix-fb76c213edcb0ef8a403ddc03d27d6975afe1a10.zip
Fix test_ptymaster_drop after PR #1098
This test cannot be compiled under Redox. PR #1098 attempted to disable it for Redox, but actually disabled it everywhere. AFAICT, Cargo has no syntax to conditionally enable a target, except based on features. Instead, use conditional compilation within the test.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e9ce0862..b5c017f7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -58,6 +58,6 @@ name = "test-mount"
path = "test/test_mount.rs"
harness = false
-[[target.'cfg(not(target_os = "redox"))'.test]]
+[[test]]
name = "test-ptymaster-drop"
path = "test/test_ptymaster_drop.rs"