summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMichael Neumann <mneumann@ntecs.de>2017-11-17 12:23:41 +0100
committerMichael Neumann <mneumann@ntecs.de>2017-12-19 10:45:23 +0100
commit709cbdf12cacb6ecf42cca9000d1d46380b6ba62 (patch)
treeca4959e8ee070e910e3cb398dc6848c1135feb94 /Cargo.toml
parentf778523d4d557ad2af720b33998b7b81c375c8e5 (diff)
downloadnix-709cbdf12cacb6ecf42cca9000d1d46380b6ba62.zip
Fix support for DragonFly
* DragonFly does not have a O_DSYNC flag * Fix type_of_cmsg_data on DragonFly * No fexecve() on DragonFly * Do not run aio test cases on DragonFly * Keep target lists in alphabetical order * Unscrable #[cfg] directives and use cfg_if! macro instead * Fix errno on DragonFly Below follows an explanation why we have to use a C extension to get errno working on DragonFly: DragonFly uses a thread-local errno variable, but #[thread_local] is feature-gated and not available in stable Rust as of this writing (Rust 1.21.0). We have to use a C extension (src/errno_dragonfly.c) to access it. Tracking issue for `thread_local` stabilization: https://github.com/rust-lang/rust/issues/29594 Once this becomes stable, we can remove build.rs, src/errno_dragonfly.c, remove the build-dependency from Cargo.toml, and use: extern { #[thread_local] static errno: c_int; } Now all targets will use the build.rs script, but only on DragonFly this will do something. Also, there are no additional dependencies for targets other than DragonFly (no gcc dep).
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f9e37545..6eff225e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,6 +18,9 @@ bitflags = "1.0"
cfg-if = "0.1.0"
void = "1.0.2"
+[target.'cfg(target_os = "dragonfly")'.build-dependencies]
+gcc = "0.3"
+
[dev-dependencies]
lazy_static = "1"
rand = "0.3.8"