diff options
author | Alan Somers <asomers@gmail.com> | 2017-07-15 10:47:58 -0600 |
---|---|---|
committer | Alan Somers <asomers@gmail.com> | 2017-07-15 23:06:45 -0600 |
commit | 5fb4cebcc6c9b241668d36c8732c93e1978b135e (patch) | |
tree | 38120e8d223f3053d2e5451b4e46e569cb99c3e7 /Cargo.toml | |
parent | da49f2aa5265bcf667469d5ab5ac8253d53da7d7 (diff) | |
download | nix-5fb4cebcc6c9b241668d36c8732c93e1978b135e.zip |
PtyMaster::drop should panic on EBADF
Also, document the double-close risk with unistd::close
Fixes #659
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 4 |
1 files changed, 4 insertions, 0 deletions
@@ -48,3 +48,7 @@ test = true name = "test-mount" path = "test/test_mount.rs" harness = false + +[[test]] +name = "test-ptymaster-drop" +path = "test/test_ptymaster_drop.rs" |