diff options
author | bors[bot] <26634292+bors[bot]@users.noreply.github.com> | 2022-03-20 14:50:14 +0000 |
---|---|---|
committer | GitHub <noreply@github.com> | 2022-03-20 14:50:14 +0000 |
commit | 1acf27ce27918badbf799815f5059b22d0fbe87f (patch) | |
tree | cbbcc45543e1307ed539ea21e64b223053fac24e /Cargo.toml | |
parent | 445a4387ada6e71e226aaf9d6087174bd5102843 (diff) | |
parent | e3983d16208333b33382e40f116c0de25bb90469 (diff) | |
download | nix-1acf27ce27918badbf799815f5059b22d0fbe87f.zip |
Merge #1683
1683: Fix build for Redox and uclibc r=asomers a=rtzoeller
- Redox renamed `sigaction.sa_handler` to `.sa_sigaction`, which lets us drop some specialized code for the platform.
- uclibc now uses a `u32` for the `RLIMIT` definitions, like Linux GNU.
Co-authored-by: Ryan Zoeller <rtzoeller@rtzoeller.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -27,7 +27,7 @@ targets = [ ] [dependencies] -libc = { version = "0.2.115", features = [ "extra_traits" ] } +libc = { version = "0.2.121", features = [ "extra_traits" ] } bitflags = "1.1" cfg-if = "1.0" |