summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlan Somers <asomers@gmail.com>2023-06-27 17:30:35 -0600
committerAlan Somers <asomers@gmail.com>2023-06-27 21:26:18 -0600
commit1546857f8c6a8ccd444eb656f4421003a376f5cd (patch)
tree05b9dad5c01c4f752a8913a3b007a638071ee0f1 /Cargo.toml
parent9a3010b62bdd61aa7d5d221af2ea3d72868dd59e (diff)
downloadnix-1546857f8c6a8ccd444eb656f4421003a376f5cd.zip
For invalid IP address conversions with future Rust versions
Rust's standard library no longer guarantees that Ipv4Addr and Ipv6Addr are wrappers around the C types (though for now at least, they are identical on all platforms I'm aware of). So do the conversions explicitly instead of transmuting. Fixes #2053
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ee3882ac..996d1d30 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -31,7 +31,6 @@ libc = { version = "0.2.141", features = ["extra_traits"] }
bitflags = "1.1"
cfg-if = "1.0"
pin-utils = { version = "0.1.0", optional = true }
-static_assertions = "1"
memoffset = { version = "0.9", optional = true }
[features]