summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlan Somers <asomers@gmail.com>2022-04-09 16:32:39 -0600
committerAlan Somers <asomers@gmail.com>2022-04-09 16:32:39 -0600
commit145c240cfac980db0cce774b9a5f438afc94342a (patch)
tree4002725c89229c90ff362a70c30bb32ec2eece38 /Cargo.toml
parent256707e8c77d47b07c21948cc8f1457655831019 (diff)
downloadnix-145c240cfac980db0cce774b9a5f438afc94342a.zip
Use singular number for all feature names
features => feature users => user Neither of these features have yet been included in a release, so it's ok to rename them.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1e2aad22..8842fc90 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -36,11 +36,11 @@ memoffset = { version = "0.6.3", optional = true }
[features]
default = [
- "acct", "aio", "dir", "env", "event", "features", "fs",
+ "acct", "aio", "dir", "env", "event", "feature", "fs",
"hostname", "inotify", "ioctl", "kmod", "mman", "mount", "mqueue",
"net", "personality", "poll", "process", "pthread", "ptrace", "quota",
"reboot", "resource", "sched", "signal", "socket", "term", "time",
- "ucontext", "uio", "users", "zerocopy",
+ "ucontext", "uio", "user", "zerocopy",
]
acct = []
@@ -48,7 +48,7 @@ aio = []
dir = ["fs"]
env = []
event = []
-features = []
+feature = []
fs = []
hostname = []
inotify = []
@@ -73,7 +73,7 @@ term = []
time = []
ucontext = ["signal"]
uio = []
-users = ["features"]
+user = ["feature"]
zerocopy = ["fs", "uio"]
[dev-dependencies]