summaryrefslogtreecommitdiff
path: root/mlua_derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'mlua_derive/Cargo.toml')
-rw-r--r--mlua_derive/Cargo.toml9
1 files changed, 8 insertions, 1 deletions
diff --git a/mlua_derive/Cargo.toml b/mlua_derive/Cargo.toml
index 60d3abe..dd99a29 100644
--- a/mlua_derive/Cargo.toml
+++ b/mlua_derive/Cargo.toml
@@ -11,7 +11,14 @@ license = "MIT"
[lib]
proc-macro = true
+[features]
+macros = ["proc-macro-error", "itertools", "regex", "once_cell"]
+
[dependencies]
-proc-macro2 = "1.0"
quote = "1.0"
+proc-macro2 = { version = "1.0", features = ["span-locations"] }
+proc-macro-error = { version = "1.0", optional = true }
syn = { version = "1.0", features = ["full"] }
+itertools = { version = "0.10", optional = true }
+regex = { version = "1.4", optional = true }
+once_cell = { version = "1.5", optional = true }